zoukankan      html  css  js  c++  java
  • Hdu 1398 Square Coins

    People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
    There are four combinations of coins to pay ten credits:

    ten 1-credit coins,
    one 4-credit coin and six 1-credit coins,
    two 4-credit coins and two 1-credit coins, and
    one 9-credit coin and one 1-credit coin.

    Your mission is to count the number of ways to pay a given amount using coins of Silverland.
     
    Input
    The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
     
    Output
    For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
     
    Sample Input
    2 10 30 0
     
    Sample Output
    1 4 27
     
     

    #include <iostream>
    #include <cstdio>
    #include <string.h>
    using namespace std;
    int a[303],b[303];
    int main()
    {
        //freopen("in.txt","r",stdin);
        int i,j,k,t;
        for(i=0;i<=300;i++)
          a[i]=b[i]=1;
        for(k=2;k<=17;k++)
        {
            t=k*k;
          for(j=t;j<=300;j+=t)
            for(i=0;i+j<=300;i++)
              a[i+j]+=b[i];
         for(i=0;i<=300;i++)
           b[i]=a[i];
        }
        while(scanf("%d",&i),i)
        {
            printf("%d\n",a[i]);
        }


     return 0;
    }

  • 相关阅读:
    Linux 系统挂载数据盘
    Apache Rewrite规则笔记
    linux fdisk分区笔记
    阿里云linux配置
    linux 下安装mysql相关笔记
    ShopNC目录结构分析
    今天开始出发做ShopNC
    svn相关笔记
    linux学习笔记-不定时更新
    Oracle EBS Java Applet报错:找不到类
  • 原文地址:https://www.cnblogs.com/372465774y/p/2429854.html
Copyright © 2011-2022 走看看