zoukankan      html  css  js  c++  java
  • HDU 1789 Doing Homework again

    Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
     


    Input
    The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
    Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
     


    Output
    For each test case, you should output the smallest total reduced score, one line per test case.
     


    Sample Input
    3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
     


    Sample Output
    0 3 5
     


    Author

    #include <stdio.h>
    #include <stdlib.h>
    #include <string.h>
    typedef struct st
    {

        int
    d;
        int
    s;
    }
    St;
    int
    cmp(const void *a,const void *b)
    {

          return
    (*(St*)b).s-(*(St*)a).s;
    }

    int
    main()
    {
      
        St p[1001];
        int
    a[1001];
        int
    i,t,j,n,min;
        scanf("%d",&t);
        while
    (t--)
        {

            scanf("%d",&n);
            for
    (i=0;i<n;i++)
              scanf("%d",&p[i].d);
            for
    (i=0;i<n;i++)
              scanf("%d",&p[i].s);
           qsort(p,n,sizeof(p[0]),cmp);
           memset(a,0,sizeof(a));min=0;
           for
    (i=0;i<n;i++)
           {

             for
    (j=p[i].d-1;j>=0;j--)
                if
    (a[j]==0)
                {
    a[j]=p[i].s;break;}
             if
    (j==-1)
                min+=p[i].s;
           }

          printf("%d\n",min);
        }

        return
    0;
    }

  • 相关阅读:
    网页请求过滤器Filter
    高级查询
    SQL编程
    数据库的实现
    数据库设计
    使用ADO.NET查询和操作数据
    使用ADO.NET访问数据库
    深入C#中的String类
    使用属性升级MyBank
    C#语法快速热身
  • 原文地址:https://www.cnblogs.com/372465774y/p/2433461.html
Copyright © 2011-2022 走看看