zoukankan      html  css  js  c++  java
  • hdu 1087 Super Jumping! Jumping! Jumping!

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     
    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the maximum according to rules, and one line one case.
     
    Sample Input
    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0
     
    Sample Output
    4
    10
    3

    //求最大递增子序列和 sum[i]=max(sum[0]...sum[i-1])&&a[0..i-1]<a[i]

    #include <stdio.h>
    #include <string.h>
    int main()
    {
        int a[1003],sum[1000];
        int i,j,n,max,m;
        while(scanf("%d",&n),n)
        {
            for(i=0;i<n;i++)
             scanf("%d",&a[i]);
            sum[0]=a[0];max=a[0];
            for(i=1;i<n;i++)
             {
                  m=0;
                 for(j=i-1;j>=0;j--)
                   if(a[j]<a[i]&&sum[j]>m)
                      m=sum[j];
                 sum[i]=m+a[i];
                 if(sum[i]>max)
                   max=sum[i];
             }
          printf("%d\n",max);
        }
        return 0;
    }

  • 相关阅读:
    Codeforces 858B
    区域赛前立FLAG
    GCJ Practice Contest
    UVa 10004 Bicoloring
    UVa 784 Maze Exploration
    Pacemaker+ISCSI实现Apache高可用-环境准备
    多机免密互信
    HAPROXY + Keepalived
    LVS+KEEPALIVED
    oracle-数据库被注入恶意攻击程序的案例恢复
  • 原文地址:https://www.cnblogs.com/372465774y/p/2441280.html
Copyright © 2011-2022 走看看