zoukankan      html  css  js  c++  java
  • POJ 2387 Til the Cows Come Home(Dijkstra)

    Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

    Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

    Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

    Input

    * Line 1: Two integers: T and N

    * Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

    Output

    * Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

    Sample Input

    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100

    Sample Output

    90

    //简单的Dijkstra使用,没有其它技巧,可以用来熟练模板、、、想学堆优化!!!!

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #define N 1003
    using namespace std;
    int p[N][N];
    int main()
    {  //freopen("in.txt","r",stdin);
        int T,n,i,j,min,x,y,cost;
        bool f[N];
        while(scanf("%d%d",&T,&n)!=EOF)
        {
           memset(f,0,sizeof(f));
           for(i=1;i<=n;i++)
              for(j=1;j<=n;j++)
                 p[i][j]=0xffffff;
          for(i=0;i<T;i++)
          {
              scanf("%d%d%d",&x,&y,&cost);
              p[x][y]=p[x][y]<cost?p[x][y]:cost;
              p[y][x]=p[x][y];
          }
          f[1]=1;x=n-1;
          cost=0;
          while(x--)
          {
              min=0xffffff;
              for(i=2;i<=n;i++)
                if(!f[i]&&p[1][i]<min)
                {
                    min=p[1][i];
                    j=i;
                }
                f[j]=1;
             for(i=2;i<=n;i++)
               if(!f[i]&&p[j][i]+p[1][j]<p[1][i])
                  p[1][i]=p[j][i]+p[1][j];
          }
          printf("%d\n",p[1][n]);
        }
        return 0;
    }

  • 相关阅读:
    windows加固方案
    redis集群
    tar命令
    nfs安装配置
    nginx php版本隐藏
    细谈select函数(C语言)
    linux 下各errno的意义(转)
    iperf交叉编译:
    主机和虚拟机不能ping通问题
    Linux中tcpdump的编译和使用
  • 原文地址:https://www.cnblogs.com/372465774y/p/2464765.html
Copyright © 2011-2022 走看看