zoukankan      html  css  js  c++  java
  • POJ 3250 Bad Hair Day

    Bad Hair Day
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 10202   Accepted: 3412

    Description

    Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

    Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

    Consider this example:

            =
    =       =
    =   -   =         Cows facing right -->
    =   =   =
    = - = = =
    = = = = = =
    1 2 3 4 5 6

    Cow#1 can see the hairstyle of cows #2, 3, 4
    Cow#2 can see no cow's hairstyle
    Cow#3 can see the hairstyle of cow #4
    Cow#4 can see no cow's hairstyle
    Cow#5 can see the hairstyle of cow 6
    Cow#6 can see no cows at all!

    Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

    Input

    Line 1: The number of cows, N.
    Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

    Output

    Line 1: A single integer that is the sum of c1 through cN.

    Sample Input

    6
    10
    3
    7
    4
    12
    2

    Sample Output

    5

    Source

     
     
     
     
    大一即将结束了、期末基本考好了、期待暑假的训练,成长
     
    本题是栈的应用
    把数压入栈,发现有数比栈顶大、就出栈,就是把区间中小的数舍掉,数出栈时计算ci;
     
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #define N 80003
    using namespace std;
    struct node
    {
        int index,val;
    }re[N];
    int main()
    {
        int n,i,h;
        __int64 sum;
        node S[N];
        while(scanf("%d",&n)!=EOF)
        {
            h=sum=0;
            scanf("%d",&re[0].val),re[0].index=0;
            S[++h]=re[0];
            for(i=1;i<n;i++)
            {
                scanf("%d",&re[i].val),re[i].index=i;
                while(h>0&&S[h].val<=re[i].val)
                {
                   sum+=i-S[h].index-1;
                   h--;
                }
                S[++h]=re[i];
            }
           while(h>0&&S[h].val<=2147480000)
                {
                   sum+=n-S[h].index-1;
                   h--;
                }
            printf("%I64d\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    E4A易安卓3.6无需注册编译Release
    PHP中几种常用的网页跳转代码
    超详细教你重新封装GHO(ndeer和绿茶)教程
    程序员和编码员之间的区别
    迅闪三层下载游戏无速度
    POST注册DZ论坛或发帖
    解决局域网文件共享设置
    妻子 情人 红颜知己
    照片与同行元素居中的方法
    【转】SVN使用教程总结
  • 原文地址:https://www.cnblogs.com/372465774y/p/2567260.html
Copyright © 2011-2022 走看看