zoukankan      html  css  js  c++  java
  • POJ 2524 Ubiquitous Religions

    Ubiquitous Religions
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 17089   Accepted: 8283

    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7
    

    Hint

    Huge input, scanf is recommended.
     
    // 求最大连通分量
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    int f[50001],r[50001];
    int n,m,nt;
    int find_r(int x)
    {
        if(f[x]>0)
         return f[x]=find_r(f[x]);
        return x;
    }
    void union_set(int x,int y)
    {
        x=find_r(x);
        y=find_r(y);
        if(x==y) return ;
        if(r[x]>r[y])
            f[y]=x;
         else if(r[x]==r[y])
               {
                  f[y]=x;
                  r[x]++;
               }
               else
                f[x]=y;
        nt++;
    }
    int main()
    {   int x,y,t=1;
        while(scanf("%d%d",&n,&m),n||m)
        {   nt=0;
          memset(f,0,sizeof(f));
          memset(r,0,sizeof(r));
            while(m--)
            {
                scanf("%d%d",&x,&y);
                union_set(x,y);
            }
            printf("Case %d: %d\n",t++,n-nt);
        }
        return 0;
    }
  • 相关阅读:
    网站制作常用的cms系统有哪些?
    企业网站建设中CMS系统的作用及现状
    PageAdmin企业网站制作中踩过的坑
    怎样制作网站的流程和步骤
    PageAdmin CMS建站系统可视化区块的使用教程
    PageAdmin CMS建站系统的可视化编辑体验
    企业网站建设常用CMS建站系统推荐
    PageAdmin CMS内容管理系统v4.0.11体验评测
    文本框检测回车按键或条码扫描结束回车符
    主播说联播 :铭记历史是为了创造历史 这三样东西不能丢!
  • 原文地址:https://www.cnblogs.com/372465774y/p/2579926.html
Copyright © 2011-2022 走看看