zoukankan      html  css  js  c++  java
  • HDU 1896 Stones

    Stones

    Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
    Total Submission(s): 374    Accepted Submission(s): 217


    Problem Description
    Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
    There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
     
    Input
    In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
    For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
     
    Output
    Just output one line for one test case, as described in the Description.
     
    Sample Input
    2 2 1 5 2 4 2 1 5 6 6
     
    Sample Output
    11 12
     
    Author
    Sempr|CrazyBird|hust07p43
     
    Source
     
    Recommend
    lcy
     
    //这题算做的比较有成就感,呵呵
    //将位置p作为第一优先级数据考虑,将D作为第二优先级考虑,都是小堆,这样就可以了,
    //187MS,算是很快的了,呵呵
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <queue>
    #include <vector>
    using namespace std;
    struct node
    {
      int p;
      int thr;
    };
    struct cmp
    {
        bool operator()(const node&a,const node&b)
        {
            if(a.p==b.p)
            {
                return a.thr>b.thr;
            }
            return a.p>b.p;
        }
    };
    int main()
    {
        int T;
        scanf("%d",&T);
        int n,k,max;
        node t;
        while(T--)
        {
            scanf("%d",&n);k=1;max=0;
            priority_queue<node,vector<node>,cmp> Q;
            while(n--)
            {
               scanf("%d%d",&t.p,&t.thr);
               Q.push(t);
            }
            while(!Q.empty())
            {
                if(k%2)
                {  k++;
                   t=Q.top();
                   Q.pop();
                   t.p=t.p+t.thr;
                   if(t.p>max) max=t.p;
                   Q.push(t);
                }
                else
                {  k++;
                   Q.pop();
                }
            }
            printf("%d\n",max);
        }
        return 0;
    }

  • 相关阅读:
    [编程题] 基础 [位运算基础]
    [编程题] lc [191. 位1的个数]
    [编程题] lc [69. x 的平方根]
    php 中php-fpm工作原理
    redis分布式锁
    3种Redis分布式锁的对比
    php使用数据库的并发问题(乐观锁与悲观锁)
    php观察者模式应用场景实例详解
    [Usaco2008 Jan]电话网络
    关于二分图结论的一些证明
  • 原文地址:https://www.cnblogs.com/372465774y/p/2581573.html
Copyright © 2011-2022 走看看