zoukankan      html  css  js  c++  java
  • HDU 1213 How Many Tables

    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5629    Accepted Submission(s): 2662


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     
    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     
    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     
    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     
    Sample Output
    2 4
     
    Author
    Ignatius.L
     
    Source
     
    Recommend
    Eddy

    //并查集模板题、刷水题练练手噢噢

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #define N 1003
    using namespace std;
    int n;
    int f[N],r[N];
    int find_f(int x)
    {
        if(x!=f[x])
        {
            return f[x]=find_f(f[x]);
        }
        return x;
    }
    void union_set(int x,int y)
    {
        x=find_f(x);
        y=find_f(y);
        if(x==y) return;
        n--;
        if(r[x]>r[y])
            f[y]=x;
        else if(r[x]<r[y])
             f[x]=y;
             else
             {
                f[y]=x;
                r[x]++;
             }
    }
    int main()
    {
        int m;
        int T;
        int i,a,b;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&n,&m);
          for(i=1;i<=n;i++)
            f[i]=i,r[i]=0;
          while(m--)
          {
              scanf("%d%d",&a,&b);
              union_set(a,b);
          }
          printf("%d\n",n);
        }
        return 0;
    }

  • 相关阅读:
    Django学习笔记第六篇--实战练习二--简易实现登录注册功能demo
    追踪溯源--抓住隐藏在NAT后面的罪犯
    Linux内核态、用户态简介与IntelCPU特权级别--Ring0-3
    Windows2008 IIS配置FTP站点
    .NET RSA解密、签名、验签
    Quartz.NET 入门
    使用Topshelf创建Windows服务
    xcode6 新建项目真机调试无法全屏
    .NET 二维码生成(ThoughtWorks.QRCode)
    iOS手机应用开发原型模板及开发流程
  • 原文地址:https://www.cnblogs.com/372465774y/p/2583994.html
Copyright © 2011-2022 走看看