zoukankan      html  css  js  c++  java
  • ZOJ 2833 Friendship

    Friendship

    Time Limit: 3 Seconds      Memory Limit: 32768 KB

    A friend is like a flower,
    a rose to be exact,
    Or maybe like a brand new gate
    that never comes unlatched.

    A friend is like an owl,
    both beautiful and wise.
    Or perhaps a friend is like a ghost,
    whose spirit never dies.

    A friend is like a heart that goes
    strong until the end.
    Where would we be in this world
    if we didn't have a friend?

                           - By Emma Guest

    Now you've grown up, it's time to make friends. The friends you make in university are the friends you make for life. You will be proud if you have many friends.

    Input

    There are multiple test cases for this problem.

    Each test case starts with a line containing two integers N, M (1 <= N <= 100'000, 1 <= M <= 200'000), representing that there are totally N persons (indexed from 1 to N) and M operations, then M lines with the form "M a b" (without quotation) or "Q a" (without quotation) follow. The operation "M a b" means that person a and b make friends with each other, though they may be already friends, while "Q a" means a query operation.

    Friendship is transitivity, which means if a and b, b and c are friends then a and c are also friends. In the initial, you have no friends except yourself, when you are freshman, you know nobody, right? So in such case you have only one friend.

    Output

    For each test case, output "Case #:" first where "#" is the number of the case which starts from 1, then for each query operation "Q a", output a single line with the number of person a's friends.

    Separate two consecutive test cases with a blank line, but Do NOT output an extra blank line after the last one.

    Sample Input

    3 5
    M 1 2
    Q 1
    Q 3
    M 2 3
    Q 2
    5 10
    M 3 2
    Q 4
    M 1 2
    Q 4
    M 3 2
    Q 1
    M 3 1
    Q 5
    M 4 2
    Q 4

    Sample Output

    Case 1:
    2
    1
    3

    Case 2:
    1
    1
    3
    1
    4

    Notes

    This problem has huge input and output data, please use 'scanf()' and 'printf()' instead of 'cin' and 'cout' to avoid time limit exceed.

    //算是并查集模板题了

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <cmath>
    #define Y 100003
    using namespace std;
    int f[Y],r[Y],h[Y];
    int Find(int x)
    {
        if(x!=f[x])
         return f[x]=Find(f[x]);
        return x;
    }
    void union_set(int x,int y)
    {
        x=Find(x);
        y=Find(y);
        if(x==y) return ;
        if(r[x]>r[y])
             f[y]=x,h[x]+=h[y];
        else if(r[x]==r[y])
             r[x]++,f[y]=x,h[x]+=h[y];
             else
             f[x]=y,h[y]+=h[x];
    }
    int main()
    {
        int N,M,t=1;
        bool b=1;
        char c;
        int x,y;
        while(scanf("%d%d",&N,&M)!=EOF)
        {
            if(b) b=0;else printf("\n");
            printf("Case %d:\n",t++);
             for(int i=1;i<=N;i++)
               f[i]=i,r[i]=h[i]=1;
             while(M--)
             {
                 getchar();
                 scanf("%c",&c);
                 if(c=='M')
                   {
                       scanf("%d%d",&x,&y);
                       union_set(x,y);
                   }
                   else
                   {
                       scanf("%d",&x);
                       x=Find(x);
                       printf("%d\n",h[x]);
                   }
             }
        }
        return 0;
    }

  • 相关阅读:
    PHP的几个常用加密函数
    sha1() 函数
    微信支付接口文档
    最强PostMan使用教程(1)
    用 Graphviz画神经网络图
    绘图工具graphviz学习使用
    maven添加oracle jdbc依赖
    httrack,webdup,WinHTTrack,WebZip
    过滤ASCII码中的不可见字符, ASCII三部分, 各控制字符详解, 去^@,^M
    报LinkageError的原因
  • 原文地址:https://www.cnblogs.com/372465774y/p/2589676.html
Copyright © 2011-2022 走看看