zoukankan      html  css  js  c++  java
  • HDU 3661 Assignments

    Assignments

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1075    Accepted Submission(s): 488


    Problem Description
    In a factory, there are N workers to finish two types of tasks (A and B). Each type has N tasks. Each task of type A needs xi time to finish, and each task of type B needs yj time to finish, now, you, as the boss of the factory, need to make an assignment, which makes sure that every worker could get two tasks, one in type A and one in type B, and, what's more, every worker should have task to work with and every task has to be assigned. However, you need to pay extra money to workers who work over the standard working hours, according to the company's rule. The calculation method is described as follow: if someone’ working hour t is more than the standard working hour T, you should pay t-T to him. As a thrifty boss, you want know the minimum total of overtime pay.
     

    Input
    There are multiple test cases, in each test case there are 3 lines. First line there are two positive Integers, N (N<=1000) and T (T<=1000), indicating N workers, N task-A and N task-B, standard working hour T. Each of the next two lines has N positive Integers; the first line indicates the needed time for task A1, A2…An (Ai<=1000), and the second line is for B1, B2…Bn (Bi<=1000).
     

    Output
    For each test case output the minimum Overtime wages by an integer in one line.
     

    Sample Input
    2 5 4 2 3 5
     

    Sample Output
    4
     

    Source
     

    Recommend
    lcy

     //贪心题目,算是比较代码比较简单的了、刚开始看后我还真不会做、郁闷,其实就是尽可能把每个工人都把限定的时间用完了去,一个升序、一个降序、开始也不理解为什么这样就是对的了,貌似这样会让浪费尽可能小

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <cmath>
    #define Y 1003
    using namespace std;
    bool cmp(const int&a,const int&b)
    {
        return a>b;
    }
    int main()
    {
        int a[Y],b[Y];
        int N,T;
        int sum;
        while(scanf("%d%d",&N,&T)!=EOF)
        {   int i;
            for(i=0;i<N;i++)
             scanf("%d",&a[i]);
            for(i=0;i<N;i++)
             scanf("%d",&b[i]);
            sort(a,a+N);
            sort(b,b+N,cmp);
            for(sum=i=0;i<N;i++)
             if(a[i]+b[i]>T)
              sum+=a[i]+b[i]-T;
            printf("%d\n",sum);
        }
        return 0;
    }

  • 相关阅读:
    【 一次性密码】TOTP
    动态令牌-(OTP,HOTP,TOTP)-基本原理
    动态口令
    Jmeter参数化 CSV Data Set Config界面说明
    Jmeter测试监控 Summary Report界面
    jmeter命令行参数
    jmeter场景设计
    jmeter事务控制器
    软件测试模型
    业务流程测试
  • 原文地址:https://www.cnblogs.com/372465774y/p/2589850.html
Copyright © 2011-2022 走看看