zoukankan      html  css  js  c++  java
  • HDU 2828 Buy Tickets

    Buy Tickets
    Time Limit: 4000MS   Memory Limit: 65536K
    Total Submissions: 7553   Accepted: 3599

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    Source

    //这题有逆向思维呀、呵呵、自己还真想不到
    //要从后往前找空格数就是了、我把pi当成找第pi+1个空格了

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #define lson l,m,k<<1
    #define rson m+1,r,k<<1|1
    #define N 200001
    using namespace std;
    int st[N<<2];//记录区间空格数
    int re[N],va;
    void up(int &k)
    {
        st[k]=st[k<<1]+st[k<<1|1];
    }
    void build(int l,int r,int k)
    {
        if(l==r)
        {
            st[k]=1;
            return ;
        }
        int m=(l+r)>>1;
        build(lson);
        build(rson);
        up(k);
    }
    void fd(int index,int l,int r,int k)
    {
         st[k]--;
         if(l==r)
         {
             re[l]=va;
             return ;
         }
         int m=(l+r)>>1;
         if(st[k<<1]>=index)
          fd(index,lson);
         else
          fd(index-st[k<<1],rson);
    }
    int te[N][2];
    int main()
    {
        int n;
        while(scanf("%d",&n)!=EOF)
        {
            build(1,n,1);
            for(int i=0;i<n;i++)
             scanf("%d%d",&te[i][0],&te[i][1]);
            for(int i=n-1;i>=0;i--)
              va=te[i][1],fd(te[i][0]+1,1,n,1);
            for(int i=1;i<n;i++)
              printf("%d ",re[i]);
            printf("%d\n",re[n]);
        }
        return 0;
    }

  • 相关阅读:
    主成分分析法(PCA)答疑
    搜索引擎的高级用法
    Makefile 编写实例
    GCC常用命令
    一个进程最多能开多少个线程?
    归并排序
    选择排序(数组、链表)
    求连续子数组的最大和
    生产者-消费者问题(1)
    基于cmake编译安装MySQL-5.5
  • 原文地址:https://www.cnblogs.com/372465774y/p/2596775.html
Copyright © 2011-2022 走看看