zoukankan      html  css  js  c++  java
  • POJ 1995 Raising Modulo Numbers

    Raising Modulo Numbers
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 3553   Accepted: 1962

    Description

    People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

    Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.

    You should write a program that calculates the result and is able to find out who won the game.

    Input

    The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

    Output

    For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

    (A1B1+A2B2+ ... +AHBH)mod M.

    Sample Input

    3
    16
    4
    2 3
    3 4
    4 5
    5 6
    36123
    1
    2374859 3029382
    17
    1
    3 18132
    

    Sample Output

    2
    13195
    13
    

    Source

    //算是 (A^B)%n的升级版了吧、呵呵

    #include <iostream>
    #include <stdio.h>
    using namespace std;
    int M;
    int del(int &a,int &b)
    {
        int t=1;
        for(;b>0;b>>=1,a=(a*a)%M)
           if(b&1)t=(a*t)%M;
        return t;
    }
    int main()
    {
        int T;
        scanf("%d",&T);
        int n;
        int a,b;
        int sum;
        while(T--)
        {
            scanf("%d",&M);
            scanf("%d",&n);
            sum=0;
            while(n--)
            {
                scanf("%d%d",&a,&b);
                a=a%M;
                sum+=del(a,b);
            }
            printf("%d\n",sum%M);

        }
        return 0;
    }

  • 相关阅读:
    ACDream
    HDU
    拼音码和五笔码生成规则
    XML与DataTable相互转换
    如何给gridControl动态的添加合计
    SqlBulkCopy将DataTable中的数据批量插入数据库中
    截取中间字符
    将Excel表格数据转换成Datatable
    DevExpress GridControl 使用方法技巧 总结 收录整理
    C#小技巧
  • 原文地址:https://www.cnblogs.com/372465774y/p/2603635.html
Copyright © 2011-2022 走看看