zoukankan      html  css  js  c++  java
  • hdu 1082 Matrix Chain Multiplication

    Matrix Chain Multiplication

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 620    Accepted Submission(s): 426


    Problem Description
    Matrix multiplication problem is a typical example of dynamical programming.

    Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
    For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
    There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
    The first one takes 15000 elementary multiplications, but the second one only 3500.

    Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.
     
    Input
    Input consists of two parts: a list of matrices and a list of expressions.
    The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
    The second part of the input file strictly adheres to the following syntax (given in EBNF):

    SecondPart = Line { Line } <EOF>
    Line = Expression <CR>
    Expression = Matrix | "(" Expression Expression ")"
    Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
     
    Output
    For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.
     
    Sample Input
    9
    A 50 10
    B 10 20
    C 20 5
    D 30 35
    E 35 15
    F 15 5
    G 5 10
    H 10 20
    I 20 25
    A
    B
    C
    (AA)
    (AB)
    (AC)
    (A(BC))
    ((AB)C)
    (((((DE)F)G)H)I)
    (D(E(F(G(HI)))))
    ((D(EF))((GH)I))
     
    Sample Output
    0
    0
    0
    error
    10000
    error
    3500
    15000
    40500
    47500
    15125
     
    Source
     
    //栈的应用
    //用栈来处理括号的层数 
    #include <iostream>
    #include <algorithm>
    #include <stdio.h>
    #include <string.h>
    #include <cmath>
    #include <stack>
    using namespace std;
    struct node
    {
        int m,n;
      //  bool f;
    };
    node hash[200];
    char s[1000];
    int main()
    {
        int i,n,sum;
        char c;
        bool b;
        scanf("%d",&n);
        while(n--)
        {
           getchar();
           scanf("%c",&c);
           scanf("%d%d",&hash[c].m,&hash[c].n);
        }
         node temp,temp1;
        while(scanf("%s",s)!=EOF)
        {   sum=0;b=1;
            stack<char> s1;
            stack<node> s2;
            for(i=0;s[i]!='\0';i++)
            {
                if(s[i]=='(')
                   s1.push(s[i]);
                else if(s[i]==')')
                     {
                         c=s1.top();
                         s1.pop();
                         s1.pop();
                         while(!s1.empty()&&s1.top()!='(')
                               {
                                  temp=s2.top();
                                  s2.pop();
                                  temp1=s2.top();
                                 if(temp1.n!=temp.m)
                                 {
                                     b=0;break;
                                 }
                                  sum+=temp1.m*temp1.n*temp.n;
                                  temp1.n=temp.n;
                                  s2.pop();
                                  s2.push(temp1);
                                  s1.pop();
                                }
                           s1.push(c);
                     }
                     else
                     {
                         if(!s1.empty()&&s1.top()!='(')
                         {
                             temp=s2.top();
                             if(temp.n!=hash[s[i]].m)
                             {
                                 b=0;break;
                             }
                             sum+=temp.m*temp.n*hash[s[i]].n;
                             temp.n=hash[s[i]].n;
                             s2.pop();
                             s2.push(temp);
                         }
                         else
                         {
                             s2.push(hash[s[i]]);
                             s1.push('#');
                         }
                     }
            }
            if(b)
              printf("%d\n",sum);
            else
             printf("error\n");
        }
        return 0;
    }
  • 相关阅读:
    剑桥雅思写作高分范文ESSAY81
    maven安装配置
    IntelliJ IDEA 2017.3.1安装步骤
    Git基本命令整理
    jacoco覆盖率工具测试及性能分析
    OSGI框架
    查看指定库对应GCC版本
    普元eos、soa、esb
    emp架构
    jar包安装到本地仓库
  • 原文地址:https://www.cnblogs.com/372465774y/p/2614328.html
Copyright © 2011-2022 走看看