zoukankan      html  css  js  c++  java
  • hdu 1081 To The Max

    To The Max

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4825    Accepted Submission(s): 2281


    Problem Description
    Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

    As an example, the maximal sub-rectangle of the array:

    0 -2 -7 0
    9 2 -6 2
    -4 1 -4 1
    -1 8 0 -2

    is in the lower left corner:

    9 2
    -4 1
    -1 8

    and has a sum of 15.
     
    Input
    The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
     
    Output
    Output the sum of the maximal sub-rectangle.
     
    Sample Input
    4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
     
    Sample Output
    15
     
    Source
    //hdu 1003 升级版
     

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <queue>
    #define N 133
    using namespace std;
    int dpsum[N][N];
    int a[N][N];
    int Max,n;
    void dp(int &i,int &len)
    {
        int r=i+len-1,l=i-1;
        int k,m_ax,b=dpsum[1][r]-dpsum[1][l];
        m_ax=b;
        for(k=2;k<=n;k++)
        {
            if(b<0)
              b=dpsum[k][r]-dpsum[k][l];
            else
             b+=dpsum[k][r]-dpsum[k][l];
            if(b>m_ax)
              m_ax=b;
        }
        Max=max(Max,m_ax);
    }
    int main()
    {
        int i,j,k;
        int l;
        while(scanf("%d",&n)!=EOF)
        {
           for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            {
                scanf("%d",&a[i][j]);
                dpsum[i][j]=dpsum[i][j-1]+a[i][j];
            }
            Max=0;
           for(l=1;l<=n;l++)//求宽度为l的子矩阵和
            {  
                j=n-l+1;
                for(i=1;i<=j;i++)
                  dp(i,l);
            }
          printf("%d\n",Max);
        }
        return 0;
    }

  • 相关阅读:
    物联网需要自己的专有操作系统
    基于visual Studio2013解决C语言竞赛题之0201温度转换
    基于visual Studio2013解决C语言竞赛题之前言
    物联网操作系统再思考:建设更加主动的网络,面向连接一切的时代
    经典排序算法分析和代码-下篇
    Windows XP硬盘安装Ubuntu 12.04双系统图文详解
    Eclipse 编码区-保护色-快捷大全
    Android最新源码4.3下载-教程 2013-11
    Windows XP硬盘安装Ubuntu 12.04双系统图文详解
    惠威的M200MK3的前级电子分频板
  • 原文地址:https://www.cnblogs.com/372465774y/p/2617948.html
Copyright © 2011-2022 走看看