zoukankan      html  css  js  c++  java
  • POJ 2533 Longest Ordered Subsequence

    Longest Ordered Subsequence
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 23690   Accepted: 10236

    Description

    A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

    Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

    Input

    The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

    Output

    Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

    Sample Input

    7
    1 7 3 5 9 4 8

    Sample Output

    4
    

    Source

    Northeastern Europe 2002, Far-Eastern Subregion
    //经典动规

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <queue>
    #define N 1222
    using namespace std;
    int a[N];
    int n;
    int bf(int &val)
    {
        int l=0,r=n,m;
        while(l<=r)
        {
            m=(l+r)>>1;
            if(a[m]>val) r=m-1;
            else if(a[m]<val) l=m+1;
            else return m;
        }
        return l;
    }
    int main()
    {
        int i,k,index,Max;
        while(scanf("%d",&n)!=EOF)
        {
            memset(a,1,sizeof(a));
             a[0]=-1;
            for(Max=k=i=1;i<=n;i++)
              {
                  scanf("%d",&k);
                  index=bf(k);
                  a[index]=k;
                  if(index>Max)
                   Max=index;
              }
            printf("%d\n",Max);
        }
        return 0;
    }

  • 相关阅读:
    re模块的split(),sub()方法 新发现
    tf.where()&np.random.RandomState.rand()&np.vstack&np.mgrid .ravel np.c_[]
    Embedding实现1pre1
    tf.keras训练iris数据集
    tf.keras 搭建神经网络六部法
    循环计算过程(4pre1)
    池化(pooling)舍弃(dropout)& 卷积神经网络
    [C]gcc编译器的一些常用语法
    [POSIX]文件系统(概述)
    [Linux]PHP-FPM与NGINX的两种通讯方式
  • 原文地址:https://www.cnblogs.com/372465774y/p/2618055.html
Copyright © 2011-2022 走看看