zoukankan      html  css  js  c++  java
  • ZOJ Problem Set 1879

    ZOJ Problem Set - 1879
    Jolly Jumpers

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

    1 4 2 3

    is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.


    Input

    Each line of input contains an integer n < 3000 followed by n integers representing the sequence.


    Output

    For each line of input, generate a line of output saying "Jolly" or "Not jolly".


    Sample Input

    4 1 4 2 3
    5 1 4 2 -1 6


    Sample Output

    Jolly
    Not jolly


    Source: University of Waterloo Local Contest 2000.09.30

    //简单模拟题

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <queue>
    using namespace std;
    bool hash[3002];
    int a[3002];
    int main()
    {
        int n,i;
        bool f;
        while(scanf("%d",&n)!=EOF)
        {
            for(i=1;i<=n;i++)
             scanf("%d",&a[i]),hash[i]=0;
            for(f=1,i=2;i<n;i++)
            {
                if(a[i]>a[i-1])
                {
                    if(a[i]-a[i-1]>=n||a[i]-a[i-1]<1)
                       {
                           f=0;break;
                       }
                   if(!hash[a[i]-a[i-1]])
                     hash[a[i]-a[i-1]]=1;
                    else
                    {
                        f=0;break;
                    }
                }
                else
                {
                   if(a[i-1]-a[i]>=n||a[i-1]-a[i]<1)
                       {
                           f=0;break;
                       }
                   if(!hash[a[i-1]-a[i]])
                     hash[a[i-1]-a[i]]=1;
                    else
                    {
                        f=0;break;
                    }
                }
            }
            if(f) printf("Jolly\n");
            else printf("Not jolly\n");
        }
        return 0;
    }

  • 相关阅读:
    18款在线代码片段测试工具
    毫秒必争,前端网页性能最佳实践
    如何判断Javascript对象是否存在
    推荐10款免费的在线UI测试工具
    揭开Socket编程的面纱
    使用 jQuery Ajax 在页面滚动时从服务器加载数据
    对Android开发者有益的40条优化建议
    web api+递归树型结构
    asp.net Lodop实现批量打印
    asp.net lodop单个打印
  • 原文地址:https://www.cnblogs.com/372465774y/p/2618411.html
Copyright © 2011-2022 走看看