zoukankan      html  css  js  c++  java
  • poj 3126 Prime Path(BFS)

    Prime Path
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7574   Accepted: 4302

    Description

    The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
    — It is a matter of security to change such things every now and then, to keep the enemy in the dark.
    — But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
    — I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
    — No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
    — I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
    — Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

    Now, the minister of finance, who had been eavesdropping, intervened.
    — No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
    — Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
    — In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
    1033
    1733
    3733
    3739
    3779
    8779
    8179
    The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

    Input

    One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

    Output

    One line for each case, either with a number stating the minimal cost or containing the word Impossible.

    Sample Input

    3
    1033 8179
    1373 8017
    1033 1033

    Sample Output

    6
    7
    0

    Source

    //广度优先搜索搜最短距离

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <queue>
    #include <cmath>
    using namespace std;
    struct node
    {
        int val,dis;
    };
    bool is(int &n)
    {
        if(n%2==0) return false;
        int i,m=sqrt(double(n));
        for(i=3;i<=m;i++)
         if(n%i==0)
          return false;
        return true;
    }
    int n,m;
    int Cos(int val)
    {
      bool h[10000]={0};
      int i,k,t;
      node a,b;a.dis=0;a.val=val;
      queue<node >Q;
      h[val]=1;
      Q.push(a);
      while(!Q.empty())
      {
        a=Q.front();Q.pop();
        k=a.val/10*10;
        for(i=1;i<=9;i+=2)
        {
            t=k+i;
           if(is(t)&&!h[t])
           {
               if(t==m)
                return a.dis+1;
             h[t]=1;
             b.val=t;
             b.dis=a.dis+1;
             Q.push(b);
           }
        }
        t=a.val%10;
        k=a.val/100*100+t;
        for(i=0;i<=9;i++)
        {
            t=k+i*10;
           if(is(t)&&!h[t])
           {
             if(t==m)
                return a.dis+1;
             h[t]=1;
             b.val=t;
             b.dis=a.dis+1;
             Q.push(b);
           }
        }
        t=a.val%100;
        k=a.val/1000*1000+t;
        for(i=0;i<=9;i++)
        {
            t=k+i*100;
           if(is(t)&&!h[t])
           {
               if(t==m)
                return a.dis+1;
             h[t]=1;
             b.val=t;
             b.dis=a.dis+1;
             Q.push(b);
           }
        }
        k=a.val%1000;
        for(i=1;i<=9;i++)
        {
            t=k+i*1000;
           if(is(t)&&!h[t])
           {
               if(t==m)
                return a.dis+1;
             h[t]=1;
             b.val=t;
             b.dis=a.dis+1;
             Q.push(b);
           }
        }
      }
      return -1;
    }
    int main()
    {
       int t;
       scanf("%d",&t);
       int cost;
       while(t--)
       {
           scanf("%d%d",&n,&m);
           if(n==m)  {printf("0\n");continue;}
           cost=Cos(n);
           if(cost==-1)
            printf("Impossible\n");
          else
            printf("%d\n",cost);
       }
        return 0;
    }

  • 相关阅读:
    python 函数
    python控制流
    python数据类型转换
    python变量
    chardet查看字符串的编码(非常好用)
    python编码转换
    系统、浏览器兼容性测试注意事项
    python数据类型
    Python二进制转十进制算法、十进转二进制算法
    介绍几个C#正则表达式工具
  • 原文地址:https://www.cnblogs.com/372465774y/p/2618530.html
Copyright © 2011-2022 走看看