zoukankan      html  css  js  c++  java
  • ZOJ 2158 Truck History

    L - Truck History
    Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
    Submit Status
    Appoint description:
    
    Description
    
    Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.
    
    Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
    
    
    where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
    
    Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.
    
    Input Specification
    The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
    
    Output Specification
    For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
    
    Sample Input
    
    4
    aaaaaaa
    baaaaaa
    abaaaaa
    aabaaaa
    0
    
    Sample Output
    
    The highest possible quality is 1/3.
    
    Input
    Specification The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
    
    Output
    Specification For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
    
    Sample Input
    
    4
    aaaaaaa
    baaaaaa
    abaaaaa
    aabaaaa
    0
    
    Sample Output
    
    The highest possible quality is 1/3.

    //建图 求最小生成树
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    #define N 2002
    char str[N][8];
    int map[N][N];
    bool b[N];
    int n;
    int prim()
    {
        int sum=0;
        int i,k,Min;
        int t=n;
        while(--t)
        {
            Min=2222;
            for(i=1;i<n;i++)
             if(!b[i]&&Min>map[0][i])
             {
                 Min=map[0][i];
                 k=i;
             }
            b[k]=1;
            sum+=Min;
            for(i=1;i<n;i++)
            if(!b[i]&&map[k][i]<map[0][i])
             map[0][i]=map[k][i];
        }
        return sum;
    }
    int main()
    {
        int i,j,k,cnt;
        while(scanf("%d",&n),n)
        {
            for(i=0;i<n;i++)
             scanf("%s",str[i]),b[i]=0;
            for(i=0;i<n;i++)
             for(j=i+1;j<n;j++)
              {    cnt=0;
                  for(k=0;k<7;k++)
                   if(str[i][k]!=str[j][k])
                    cnt++;
                  map[i][j]=cnt;
                  map[j][i]=cnt;
              }
            printf("The highest possible quality is 1/%d.\n",prim());
        }
    
    
        return 0;
    }
  • 相关阅读:
    软件工程概论---二维最大子数组和
    电梯调度之需求分析
    梦断代码读书笔记(一)
    软件工程概论---max单元测试
    软件工程概论---最大子数组的和延伸
    软件工程概论第三周测验---最大子数组
    软件工程概论第二周综合测验
    软件工程概论第二周综合测验----设计思路
    2015年上学期读书计划
    关于阅读构建之法提出的问题
  • 原文地址:https://www.cnblogs.com/372465774y/p/2766374.html
Copyright © 2011-2022 走看看