zoukankan      html  css  js  c++  java
  • ZOJ 1914 Arctic Network

    M - Arctic Network
    Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
    Appoint description:

    Description

    The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.

    Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

    Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.


    Input

    The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).


    Output

    For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.


    Sample Input



    1
    2 4
    0 100
    0 300
    0 600
    150 750


    Sample Output



    212.13
    //求最小生成树中的第S长边
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    #define N 502
    double dis(double x,double y,double a,double b)
    {
        return sqrt((x-a)*(x-a)+(y-b)*(y-b));
    }
    double d[N][2];
    double map[N][N];
    int P;
    bool b[N];
    double rd[N];
    int id;
    void Prim()
    {
        int i,k;
        memset(b,0,sizeof(b));
        double Min;
        int t=P;
        while(--t)
        {
            Min=1000000;
            for(i=1;i<P;i++)
             if(!b[i]&&Min>map[0][i])
             {
                 Min=map[0][i];
                 k=i;
             }
            b[k]=1;
            rd[id++]=Min;
            for(i=1;i<P;i++)
            if(!b[i]&&map[k][i]<map[0][i])
             map[0][i]=map[k][i];
        }
    }
    int main()
    {
        int S;
        int T;
        int i,j,k;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d %d",&S,&P);
            for(i=0;i<P;i++)
             scanf("%lf %lf",&d[i][0],&d[i][1]);
            for(i=0;i<P;i++)
             for(j=i+1;j<P;j++)
              map[i][j]=map[j][i]=dis(d[i][0],d[i][1],d[j][0],d[j][1]);
            id=0;
            Prim();
            sort(rd,rd+id);
            printf("%.2lf\n",rd[id-S]);
        }
        return 0;
    }
    
    
  • 相关阅读:
    Spring中的destroy-method方法
    github Pull Request合入全流程介绍
    vue-router动态路由设置参数可选
    github上fork原项目,如何将本地仓库代码更新到最新版本?
    github的pull Request使用
    vue2.X版本vue-cli生成项目后运行失败,报错信息为getaddrinfo ENOTFOUND localhost
    npm在linux即mac下更新时报错
    数组Array和字符串String的indexOf方法,以及ES7(ES2016)中新增的Array.prototype.includes方法
    less的使用总结
    ssh连接github连不上
  • 原文地址:https://www.cnblogs.com/372465774y/p/2766379.html
Copyright © 2011-2022 走看看