zoukankan      html  css  js  c++  java
  • ZOJ 2048 Highways

    N - Highways
    Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
    Submit Status
    Appoint description:
    
    Description
    The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.
    
    Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.
    
    The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
    
    
    Input
    
    The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.
    
    The first line of the input contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.
    
    The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
    
    
    Output
    
    Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.
    
    If no new highways need to be built (all towns are already connected), then the output should be created but it should be empty.
    
    
    This problem contains multiple test cases!
    
    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
    
    The output format consists of N output blocks. There is a blank line between output blocks.
    
    
    Sample Input
    
    1
    
    9
    1 5
    0 0
    3 2
    4 5
    5 1
    0 4
    5 2
    1 2
    5 3
    3
    1 3
    9 7
    1 2
    
    
    Sample Output
    
    1 6
    3 7
    4 9
    5 7
    8 3

    //求最小生成树 将新加入的边的2个端点输出来
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    #define N 755
    double dis(double x,double y,double a,double b)
    {
        return sqrt((x-a)*(x-a)+(y-b)*(y-b));
    }
    double d[N][2];
    double map[N][N];
    bool b[N];
    double ds[N];
    int f[N],n;
    void Prim()
    {
        int i,k;
        memset(b,0,sizeof(b));
        double Min;
        int t=n;
        while(--t)
        {
            Min=1000000;
            for(i=2;i<=n;i++)
             if(!b[i]&&Min>ds[i])
             {
                 Min=ds[i];
                 k=i;
             }
            b[k]=1;
            for(i=2;i<=n;i++)
            if(!b[i]&&map[k][i]<ds[i])
              {
                  f[i]=k;
                  ds[i]=map[k][i];
              }
        }
    }
    int main()
    {
        int T;
        bool fl=0;
        int i,j,k,m;
        scanf("%d",&T);
        while(T--)
        {
            if(fl) printf("\n");else fl=true;
             scanf("%d",&n);
            for(i=1;i<=n;i++)
             scanf("%lf %lf",&d[i][0],&d[i][1]),f[i]=1;
            for(i=1;i<=n;i++)
             for(j=i+1;j<=n;j++)
              map[i][j]=map[j][i]=dis(d[i][0],d[i][1],d[j][0],d[j][1]);
            scanf("%d",&m);
            for(i=1;i<=m;i++)
             {
                 scanf("%d %d",&j,&k);
                 map[j][k]=map[k][j]=0;
             }
            for(i=1;i<=n;i++)
             ds[i]=map[1][i];
            Prim();
            for(i=2;i<=n;i++)
              if(map[i][f[i]]!=0)
               printf("%d %d\n",i,f[i]);
        }
        return 0;
    }
     
  • 相关阅读:
    第二次作业
    国庆节假期作业1
    memoize使用实例之创建XHR
    javascript 函数式编程(3)
    javascript 异步循环 asyncEach
    c++ 精简版 序列化
    javascript 函数式编程(4)
    javascript setZeroTimeout
    c++ 精简版 thread
    PHP Memoization
  • 原文地址:https://www.cnblogs.com/372465774y/p/2766385.html
Copyright © 2011-2022 走看看