zoukankan      html  css  js  c++  java
  • poj 2421 Constructing Roads

    Constructing Roads
    Time Limit: 2000MS        Memory Limit: 65536K
    Total Submissions: 16528        Accepted: 6733
    
    Description
    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
    
    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
    
    Input
    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
    
    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
    
    Output
    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
    
    Sample Input
    
    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2
    
    Sample Output
    
    179
    
    Source
    PKU Monthly,kicc

    求某些点已经被连接的 最小生成树
    #include <stack>
    #include <set>
    #include <vector>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    #define N 102
    int map[N][N];
    bool b[N];
    int n;
    int Prim()
    {
        int i,sum=0,k;
        int t=n;
        int Min;
        memset(b,0,sizeof(b));
        while(--t)
        {
            Min=10000;
            for(i=2;i<=n;i++)
             if(!b[i]&&Min>map[1][i])
              {
                  Min=map[1][i];
                  k=i;
              }
           //   printf("%d ",Min);
              b[k]=1;
              sum+=Min;
              for(i=2;i<=n;i++)
               if(!b[i]&&map[k][i]<map[1][i])
                 map[1][i]=map[k][i];
        }
        return sum;
    }
    int main()
    {
        int i,j,q;
        while(scanf("%d",&n)!=EOF)
        {
            for(i=1;i<=n;i++)
             for(j=1;j<=n;j++)
              scanf("%d",&map[i][j]);
            scanf("%d",&q);
            while(q--)
            {
                scanf("%d %d",&i,&j);
                map[i][j]=0;
                map[j][i]=0;
            }
            printf("%d\n",Prim());
        }
        return 0;
    }
     
  • 相关阅读:
    龙果支付系统
    Java并发多线程
    StringRedisTemplate常用操作
    统一支付平台转型
    IntValue()方法 和 ValueOf()方法
    Java中一些知识的归纳总结
    mybatis的一些特殊符号标识(大于,小于,等于,不等于)
    MySQL中大于等于小于等于的写法
    boost::bind应用示例
    VC除零异常(错误)捕获
  • 原文地址:https://www.cnblogs.com/372465774y/p/2766427.html
Copyright © 2011-2022 走看看