zoukankan      html  css  js  c++  java
  • zoj 2750 Idiomatic Phrases Game

    Idiomatic Phrases Game
    Time Limit: 2 Seconds      Memory Limit: 65536 KB
    
    Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.
    
    Input
    
    The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
    
    Output
    
    One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
    
    Sample Input
    
    5
    5 12345978ABCD2341
    5 23415608ACBD3412
    7 34125678AEFD4123
    15 23415673ACC34123
    4 41235673FBCD2156
    2
    20 12345678ABCD
    30 DCBF5432167D
    0
    
    Sample Output
    
    17
    -1
    如果2个成语可接、那么建立一条有向边
    权值为前一个成语的时间值
    然后就是最短路径代码了
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    #define N 1002
    #define Max 1000000000
    struct node
    {
        int v;
        char front[5],back[5];
    }idiom[N];
    int map[N][N];
    bool b[N];
    int n;
    void dijskla()
    {
        memset(b,0,sizeof(b));
        b[1]=1;
        int i,k;
        int t=n,Min;
        while(--t)
        {
            Min=Max;
            for(i=2;i<=n;i++)
             if(!b[i]&&Min>map[1][i])
             {
                 k=i;
                 Min=map[1][i];
             }
            if(Min==Max) break;
            b[k]=1;
            for(i=2;i<=n;i++)
             if(!b[i]&&map[1][i]>map[1][k]+map[k][i])
             {
                 map[1][i]=map[1][k]+map[k][i];
             }
        }
    }
    int main()
    {
        int i,j,k;
        char s[100];
        int len;
        while(scanf("%d",&n),n)
        {
            for(i=1;i<=n;i++)
            {
                scanf("%d %s",&idiom[i].v,s);
                len=strlen(s);
                k=len-4;//  printf("%s ",s[k]);
                for(j=0;j<4;j++)
                 {
                     idiom[i].front[j]=s[j];
                     idiom[i].back[j]=s[k++];
                 }
                idiom[i].front[j]='\0';
                idiom[i].back[j]='\0';
               // printf("%s %s\n",idiom[i].front,idiom[i].back);
            }
            for(i=1;i<=n;i++)
             for(j=1;j<=n;j++)
             {
                 if(i==j) continue;
                 map[i][j]=Max;
                 if(strcmp(idiom[i].back,idiom[j].front)==0)
                 map[i][j]=idiom[i].v;//,printf("%d ",idiom[i].v);
             }
            dijskla();
            if(map[1][n]==Max)
              map[1][n]=-1;
              printf("%d\n",map[1][n]);
        }
        return 0;
    }
    
    
    
     
  • 相关阅读:
    hadoop基础
    数据库基础知识
    sqoop基础
    大数据之常用linux常用命令
    zooKeeper基础
    impala基础
    Hbase基础
    Commitlint 提交规范类型
    理解JS闭包
    JS函数作用域及作用域链理解
  • 原文地址:https://www.cnblogs.com/372465774y/p/2777529.html
Copyright © 2011-2022 走看看