zoukankan      html  css  js  c++  java
  • HDOJ 1198

    Farm Irrigation

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 11453    Accepted Submission(s): 4952


     

    Problem Description

    Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

    Figure 1



    Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

    ADC
    FJK
    IHE

    then the water pipes are distributed like 

    Figure 2

    Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

    Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

    Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

    Input

    There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

    Output

    For each test case, output in one line the least number of wellsprings needed.

    Sample Input

    2 2 DK HF 3 3 ADC FJK IHE -1 -1

    Sample Output

    2 3

    题解:并查集,很经典呀,一套打下来就过了,好像还能优化。懒了.

    #include<bits/stdc++.h>
    using namespace std;
    char f[51][51];
    int ma[51][51];
    int ans[3000];
    int c[12][4]={
        1,0,1,0,1,0,0,1,0,1,1,0,0,1,0,1,1,1,0,0,0,0,1,1,1,0,1,1,1,1,1,0,0,1,1,1,1,1,0,1,1,1,1,1,
    };
    int m,n;
    int d[4][2]={-1,0,1,0,0,-1,0,1,};
    void bian(int a,int b)
    {
        for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
                if(ma[i][j]==a)
                    ma[i][j]=b;
    }
    void find(int x,int y)
    {
        if(x>=n||y>=m||x<0||y<0)
            return ;
        for(int i=0;i<4;i++)
        {
            int cx=x+d[i][0],cy=y+d[i][1];
            if(cx>=n||cy>=m||cx<0||cy<0)
            continue ;
            int j=f[cx][cy]-'A';
            int k=f[x][y]-'A';
            int p;
            if(i%2) p=i-1;
            else p=i+1;
    
            if(c[k][i]==1&&c[j][p]==1&&ma[x][y]!=ma[cx][cy])
            bian(max(ma[x][y],ma[cx][cy]),min(ma[x][y],ma[cx][cy]));
        }
    }
    int main()
    {
        while(cin>>n>>m,n>0)
        {
            int sum=0;
            memset(ans,0,sizeof(ans));
            int ju=1;
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
            {
                cin>>f[i][j];
                ma[i][j]=ju;
                ju++;
            }
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
            {
              find(i,j);
              ju++;
            }
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
                    ans[ma[i][j]]++;
            for(int i=0;i<=n*m;i++)
               if(ans[i])
                sum++;
               cout<<sum<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    同时实现打开两个文件的内容
    《APUE》第四章笔记(4)
    《APUE》第四章笔记(3)
    《APUE》第四章笔记(2)
    《APUE》第四章笔记(1)
    约瑟夫环问题(报数问题)
    无符号十进制整数转换成任意进制数
    《APUE》第三章笔记(4)及习题3-2
    Edit Distance问题在两种编程范式下的求解
    Boyer and Moore Fast majority vote algorithm(快速选举算法)
  • 原文地址:https://www.cnblogs.com/37kiazz73/p/10316872.html
Copyright © 2011-2022 走看看