zoukankan      html  css  js  c++  java
  • A

    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

    There is exactly one node, called the root, to which no directed edges point.
    Every node except the root has exactly one edge pointing to it.
    There is a unique sequence of directed edges from the root to each node.
    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

    Input

    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

    Output

    For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

    Sample Input

    6 8  5 3  5 2  6 4
    5 6  0 0
    
    8 1  7 3  6 2  8 9  7 5
    7 4  7 8  7 6  0 0
    
    3 8  6 8  6 4
    5 3  5 6  5 2  0 0
    -1 -1

    Sample Output

    Case 1 is a tree.
    Case 2 is a tree.
    Case 3 is not a tree.

    题解:该题我是当作水题来做,没啥好说的。注意点数减去边数等于1和入度不能大于一。
    AC 代码如下:
    #include<stdio.h>
    #include<string.h>
    int main()
    {
         int a[1000],b[1000],x,y,d,i=1,c=0,n=0,bbb=1;
         memset(a,-1,sizeof(a));
         memset(b,0,sizeof(b));
         while(1)
         { scanf("%d%d",&x,&y);
              if(x<0||y<0)break;
              else if(x==0&&y==0)
              {
                 if(c==0)printf("Case %d is a tree. ",i++);
                 else if(bbb&&c==n+1)printf("Case %d is a tree. ",i++);
                 else printf("Case %d is not a tree. ",i++);
                 memset(a,-1,sizeof(a));
                 memset(b,0,sizeof(b));
                 c=0;n=0;bbb=1;
              }
              else
              {
                   if(bbb)
                 {
                   if(a[x]==-1){a[x]=1;c++;}
                   if(a[y]==-1){a[y]=1;c++;}
                   n++;
                   b[y]++;
                   if(b[y]>1)bbb=0;
                 }
              }


         }
         return 0;
    }
  • 相关阅读:
    alter table move
    VI常用命令
    【转】window.showModalDialog以及window.open用法简介
    这算是随想
    SQL Prompt——SQL智能提示插件
    C#和VB.NET中类型相关资料整理
    仿查询分析器的C#计算器——6.函数波形绘制
    Snippet Compiler——代码段编译工具
    仿查询分析器的C#计算器——4.语法分析
    【高效程序员系列】目录
  • 原文地址:https://www.cnblogs.com/441179572qqcom/p/5693175.html
Copyright © 2011-2022 走看看