zoukankan      html  css  js  c++  java
  • M

    Description

    John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

    Input

    The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

    Output

    For each instance, print a line with n integers representing the tasks in a possible order of execution.

    Sample Input

    	5 4
    	1 2
    	2 3
    	1 3
    	1 5
    	0 0

    Sample Output

    	1 4 2 5 3


    解题思路:拓扑排序加上dfs。不错的一道题

    代码如下:

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    using namespace std;
    int ss[101][101],num[101],daan[101],m,n,t;
    bool bfs(int i)
    {
      num[i]=-1;
      for(int t=1;t<=m;t++) if(ss[i][t]==1)
              {
                   if(num[t]==-1)return false;
                   else if(!num[t]) bfs(t);
              }
              num[i]=1;daan[t--]=i;
              return true;
    }
    bool bbb()
    {
      t=m;
      memset(num,0,sizeof(num));
      for(int y=1;y<=m;y++)
        if(!num[y]&&!bfs(y))
         return false;
         return true;
    }
    int main()
    {
         int a,b;
         while(scanf("%d%d",&m,&n)==2)
         {    memset(ss,0,sizeof(ss));
              if(m==0&&n==0)break;
              for(int i=1;i<=n;i++)
              {
                   scanf("%d%d",&a,&b);
                   ss[a][b]=1;
              }
              if(bbb())
              {
                   for(int z=1;z<m;z++)
                    printf("%d ",daan[z]);
                     printf("%d ",daan[m]);
              }
                 else printf("No ");
         }
         return 0;
    }

     
  • 相关阅读:
    TensorFlow学习笔记之四——源码分析之基本操作
    TensorFlow学习笔记之三——适合入门的一些资源
    AW286 选课(背包类树形DP)
    AW303 运输小猫
    AW302 任务安排3
    AW301 任务安排2 (斜率优化DP)
    AW300 任务安排1
    AW311 月之谜
    AW310 启示录
    AW292 炮兵阵地
  • 原文地址:https://www.cnblogs.com/441179572qqcom/p/5693293.html
Copyright © 2011-2022 走看看