zoukankan      html  css  js  c++  java
  • hdu 1209 Clock

    Clock

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5870    Accepted Submission(s): 1872


    Problem Description
    There is an analog clock with two hands: an hour hand and a minute hand. The two hands form an angle. The angle is measured as the smallest angle between the two hands. The angle between the two hands has a measure that is greater than or equal to 0 and less than or equal to 180 degrees.

    Given a sequence of five distinct times written in the format hh : mm , where hh are two digits representing full hours (00 <= hh <= 23) and mm are two digits representing minutes (00 <= mm <= 59) , you are to write a program that finds the median, that is, the third element of the sorted sequence of times in a nondecreasing order of their associated angles. Ties are broken in such a way that an earlier time precedes a later time.

    For example, suppose you are given a sequence (06:05, 07:10, 03:00, 21:00, 12:55) of times. Because the sorted sequence is (12:55, 03:00, 21:00, 06:05, 07:10), you are to report 21:00.
     
    Input
    The input consists of T test cases. The number of test cases (T) is given on the first line of the input file. Each test case is given on a single line, which contains a sequence of five distinct times, where times are given in the format hh : mm and are separated by a single space.
     
    Output
    Print exactly one line for each test case. The line is to contain the median in the format hh : mm of the times given. The following shows sample input and output for three test cases.
     
    Sample Input
    3
    00:00 01:00 02:00 03:00 04:00
    06:05 07:10 03:00 21:00 12:55
    11:05 12:05 13:05 14:05 15:05
     
    Sample Output
    02:00
    21:00
    14:05
    题意:n个测试案例,每一个测试案例5个时间,
    每一个时间的时针和分针都有一个相对应的角度,
    按角度排序,角度排序排在中间的那个时间
    {注意: 角度相同的时候   要按时间来排序}

    #include <stdlib.h>
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <vector>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    #define N 1000
    struct SS
    {
    int hh,mm;
    double r;

    }f[N];
    int cmp(SS a,SS b)
    {
    if(a.r!=b.r)
    return a.r<b.r;
    if(a.r==b.r&&a.hh!=b.hh)
    return a.hh<b.hh;

    }
    int main()
    { //freopen("1.txt","r",stdin);
    int i,test,m,n;
    cin>>test;
    while(test--)
    {
    for(i=0;i<5;i++)
    scanf("%d:%d",&f[i].hh,&f[i].mm);
    for(i=0;i<5;i++)
    {
    if(f[i].hh>12)
    {
    f[i].r=fabs(30.0*(f[i].hh-12)+f[i].mm/2.0-6.0*f[i].mm);

    }
    else
    {
    f[i].r=fabs(30.0*f[i].hh+f[i].mm/2.0-6.0*f[i].mm);

    }
    if(f[i].r>180)
    f[i].r=360-f[i].r;

    }
    sort(f,f+5,cmp);
    printf("%02d:%02d ",f[2].hh,f[2].mm);

    }
    return 0;
    }

  • 相关阅读:
    vue项目进行时,script标签中,methods事件中函数使用的async/await
    css阴影——box-shadow
    vue报错——Module not found: Error: Can't resolve 'less-loader sass' in ...
    vue组件如何引入外部.js/.css/.scss文件
    获得汉字的拼音或者拼音简写
    model转XML
    sql server 添加表注释、字段注释
    (转)SQL Server 监控统计阻塞脚本信息
    系统首页右下角弹框
    DropDownListExtend控件
  • 原文地址:https://www.cnblogs.com/52why/p/6565013.html
Copyright © 2011-2022 走看看