zoukankan      html  css  js  c++  java
  • PAT 解题报告 1013. Battle Over Cities (25)

    1013. Battle Over Cities (25)

    t is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

    For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

    Input

    Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

    Output

    For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

    Sample Input

    3 2 3
    1 2
    1 3
    1 2 3
    

    Sample Output

    1
    0
    0


    题意

    给定一张图和指定几个点。针对给出的每个点,要求计算,在除掉连接该点的路径的情况下,保证整个图连通所需要添加的边的数量。

    分析

    计算保证整个图连通需要几个点,亦即求出图中有几个连通分量。两种思路:

    • 1.并查集
    • 2.DFS

    针对每个点,执行算法的过程中,需要注意去除掉该点对应的所有通路。

    并查集:

    #include<iostream>
    #include<cstdio>
    //并查集做,AC代码
    using namespace std;
    
    int n,m,k;
    int father[1001];
    int road[500001][2];
    //用的巧妙,road[i][0]和road[i][1]表示第i条road的两端
    void makeset(int num){
        int i;
        for(i=0;i<=num;i++)
            father[i]=i;
    }
    int findset(int x){
        if(x!=father[x]) father[x]=findset(father[x]);
        return father[x];
    }
    void joinset(int x,int y){
        x=findset(x);
        y=findset(y);
        if(x==y) return ;
        else{
            father[y]=x;
        }
    }
    
    int main(){
        freopen("in.txt","r",stdin);
        int i,tmp,j;
        while(cin>>n>>m>>k){
            for(i=0;i<m;i++){
                cin>>road[i][0]>>road[i][1];
            }
    
            for(i=0;i<k;i++){
                makeset(n);
                cin>>tmp;
                for(j=0;j<m;j++){
                    if(tmp!=road[j][0] && tmp!=road[j][1]) joinset(road[j][0],road[j][1]);
                }
    
                int num=0;
                for(j=1;j<=n;j++){
                    if(father[j]==j) num++;
                }
                cout<<num-2<<endl;//去掉一个结点-1,连接-1
            }
        }
        return 0;
    }

    DFS

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    //AC了
    using namespace std;
    int n,m,k;
    int mp[1001][1001];
    int u[1001];
    
    void dfs(int v){
        u[v]=1;
        int i;
        for(i=1;i<=n;i++){
            if(u[i]==0 && mp[v][i]>0)
                dfs(i);
        }
    }
    int dfsTraverse(int s){
        int i,cnt=0;
        memset(u,0,sizeof(u));
    
        for(i=1;i<=n;i++){
            if(mp[i][s]>0) mp[i][s]=mp[s][i]=-1;
        }
    
        for(i=1;i<=n;i++){
            if(i!=s && u[i]==0){
                dfs(i);
                cnt++;
            }
        }
    
        for(i=1;i<=n;i++){
            if(mp[i][s]<0) mp[i][s]=mp[s][i]=1;
        }
    
        return cnt-1;
    }
    
    int main(){
        freopen("in.txt","r",stdin);
        int i,tmp;
        while(cin>>n>>m>>k){
            memset(mp,0,sizeof(mp));
            for(i=0;i<m;i++){
                int t1,t2;
                cin>>t1>>t2;
                mp[t1][t2]=mp[t2][t1]=1;//这里手误了
            }
            for(i=0;i<k;i++){
                cin>>tmp;
                int num = dfsTraverse(tmp);
                cout<<num<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    python有哪些关键字?让他自己“吐”出来!
    jquery获取表单元素与回显
    前端开发笔记--flex布局
    Vue-Quill-Editor回显不显示空格的处理办法
    react项目中antd组件库的使用需要注意的问题
    React Native 列表的总结
    是时候了解React Native了
    Android 整合实现简单易用、功能强大的RecyclerView
    linux centos 一键安装环境
    推翻自己和过往,重学自定义View
  • 原文地址:https://www.cnblogs.com/549294286/p/3571725.html
Copyright © 2011-2022 走看看