zoukankan      html  css  js  c++  java
  • PAT 解题报告 1050. String Subtraction (20)

    1050. String Subtraction (20)

    Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

    Input Specification:

    Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

    Output Specification:

    For each test case, print S1 - S2 in one line.

    Sample Input:

    They are students.
    aeiou
    

    Sample Output:

    Thy r stdnts.

    题意

    给定两个字符串,S1 和 S2,要求将 S2 中的字符从 S1 串中剔除。

    分析

    用 Hash 的方式标记需要剔除的字符。

    #include <iostream>
    #include <cstdio>
    #include <string>
    
    using namespace std;
    
    int main()
    {
        int hs[256] ={0};
        char cs[10001];
        gets(cs);
        string st = cs;
        //getline(cin, st);
        while (1) {
            char c = getchar();
            if (c == '
    ') break;
            hs[c] = 1;
        }
    
        for (int i=0; i<st.size(); i++) {
            if (hs[st[i]] == 0)
                printf("%c", st[i]);
        }
    
        return 0;
    }
  • 相关阅读:
    什么是级联
    @GeneratedValue
    Spring Data JPA中CrudRepository与JpaRepository的不同
    Spring Data JPA的方法命名规则
    C/S架构的渗透测试-请求加解密及测试
    各类Fuzz字典
    Nessus8.11破解
    xss实验1-20writeup
    IIS短文件名漏洞
    Linux挂载exfat文件系统的U盘
  • 原文地址:https://www.cnblogs.com/549294286/p/3574247.html
Copyright © 2011-2022 走看看