zoukankan      html  css  js  c++  java
  • 1011 World Cup Betting (20 分)

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.1  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be ( yuans (accurate up to 2 decimal places).

    Input Specification:

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

    Output Specification:

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input:

    1.1 2.5 1.7
    1.2 3.1 1.6
    4.1 1.2 1.1
    

    Sample Output:

    T T W 39.31
    题目分析:很简单,直接写就行
    #include<iostream>
    #include<string>
    #include<stdlib.h>
    #include<vector>
    #include<algorithm>
    using namespace std;
    char Array[3] = { 'W','T','L' };
    int main()
    {
        float in[3][3];
        float max[3] = { 0 };
        int flag[3] = { 0 };
        for(int i=0;i<3;i++)
            for (int j = 0; j < 3; j++)
            {
                cin >> in[i][j];
                if (in[i][j] > max[i])
                {
                    max[i] = in[i][j];
                    flag[i] = j;
                }
            }
        float Count = (max[0] * max[1] * max[2] * 0.65 - 1.0) * 2;
        printf("%c %c %c %.2f", Array[flag[0]], Array[flag[1]], Array[flag[2]], Count);
    }
  • 相关阅读:
    将训练好的Tensorflow模型部署到web应用中
    python pip升级
    python time
    python 队列模拟递归遍历目录(广度遍历)
    python 栈模拟递归遍历目录(深度遍历)
    python 递归遍历目录
    python 队列
    python 栈
    python 递归
    python 语音模块
  • 原文地址:https://www.cnblogs.com/57one/p/11867390.html
Copyright © 2011-2022 走看看