zoukankan      html  css  js  c++  java
  • 1030 Travel Plan (30分)(dijkstra 具有多种决定因素)

    A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤) is the number of cities (and hence the cities are numbered from 0 to N1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

    City1 City2 Distance Cost
    

    where the numbers are all integers no more than 500, and are separated by a space.

    Output Specification:

    For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

    Sample Input:

    4 5 0 3
    0 1 1 20
    1 3 2 30
    0 3 4 10
    0 2 2 20
    2 3 1 20
    

    Sample Output:

    0 2 3 3 40

    题目分析:单源最短路
    #define _CRT_SECURE_NO_WARNINGS
    #include <climits>
    #include<iostream>
    #include<vector>
    #include<queue>
    #include<stack>
    #include<algorithm>
    #include<string>
    #include<cmath>
    using namespace std;
    int N, M, S, D;
    int a[501][501];
    int b[501][501];
    int Dist[501];
    int Path[501];
    int Collected[501];
    int Cost[501];
    void Dijsktra()
    {
        Dist[S] = 0;
        Path[S] = -1;
        Cost[S] = 0;
        for (int i = 0; i < N; i++)
        {
            int minv=-1, min = INT_MAX;
            for (int v = 0; v < N; v++)
            {
                if (!Collected[v] && min > Dist[v])
                {
                    min = Dist[v];
                    minv = v;
                }
            }
            Collected[minv] = 1;
            for (int j = 0; j < N; j++)
            {
                if (!Collected[j] && a[minv][j] != INT_MAX)
                {
                    if (Dist[minv] + a[minv][j] < Dist[j])
                    {
                        Dist[j] = Dist[minv] + a[minv][j];
                        Cost[j] = Cost[minv] + b[minv][j];
                        Path[j] = minv;
                    }
                    else if (Dist[minv] + a[minv][j] == Dist[j])
                    {
                        if (Cost[minv] + b[minv][j] < Cost[j])
                        {
                            Cost[j] = Cost[minv] + b[minv][j];
                            Path[j] = minv;
                        }
                    }
                }
            }
        }
    }
    int main()
    {
        cin >> N >> M >> S >> D;
        int c1, c2, d, c;
        fill(a[0],a[0]+500*500,INT_MAX);
        fill(b[0], b[0]+500* 500, INT_MAX);
        fill(Dist, Dist + 500, INT_MAX);
        fill(Cost, Cost + 500, INT_MAX);
        for (int i = 0; i < M; i++)
        {
            cin >> c1 >> c2 >> d >> c;
            a[c1][c2] = a[c2][c1] = d;
            b[c1][c2] = b[c2][c1] = c;
        }
        Dijsktra();
        int temp = D;
        stack<int> st;
        while (temp!=-1)
        {
            st.push(temp);
            temp = Path[temp];
        }
        while (!st.empty())
        {
            cout << st.top()<<" ";
            st.pop();
        }
        cout << Dist[D] <<" "<<Cost[D];
        return 0; 
    }
  • 相关阅读:
    【译】第33节---种子数据
    python文件的读写
    python-----实现数据库安装和连接操作
    学习进度(第三周)
    解 idea(.IntelliJIdea2019.3)双击打不开的原因
    python爬虫------处理cookie的相关请求
    安装retrying模块出现 (Retry(total=4, connect=None, read=None, redirect=None, status=None))
    java----统计疫情可视化展示--echarts(三)
    java----统计疫情可视化展示--echarts(二)
    java----统计疫情可视化展示--echarts
  • 原文地址:https://www.cnblogs.com/57one/p/12005859.html
Copyright © 2011-2022 走看看