zoukankan      html  css  js  c++  java
  • 【STL】Message Flood(set)

    Message Flood

    Time Limit: 1500MS Memory limit: 65536K

    题目描述

    Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

    输入

    There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

    输出

    For each case, print one integer in one line which indicates the number of left friends he must send.

    示例输入

    5 3
    Inkfish
    Henry
    Carp
    Max
    Jericho
    Carp
    Max
    Carp
    0

    示例输出

    3

    【转】
    #include<iostream>
    #include<algorithm>
    #include<set>
    #include<string>
    using namespace std;
    
    int main()
    {    
        string str;
        int m,n;
        while(cin>>n && n)
        {
            set<string> myset;
            cin>>m;        
            for(int i=0;i<n;i++)
            {
                cin>>str;
                for(int j=0;j<str.length();j++)//转换成小写,坑啊
                    str[j]=tolower(str[j]);
                myset.insert(str);
            }
            for(int i=0;i<m;i++)
            {
                cin>>str;
                for(int j=0;j<str.length();j++)
                    str[j]=tolower(str[j]);
                set<string>::iterator itor=myset.find(str);
                if(itor!=myset.end())
                    myset.erase(str);
            }
            cout<<myset.size()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    linux_ssh用户枚举猜测
    Nginx 主配置文件参数详解
    OSI七层模型
    linux-Python升级安装
    qt多线程
    python 对串口的操作
    keil 下模拟u-boot的cmd功能
    <转载>CentOS 6.3下Samba服务器的安装与配置
    Magento开发完整指南
    飞书信(Facebook Messenger)是什么?
  • 原文地址:https://www.cnblogs.com/6bing/p/4125491.html
Copyright © 2011-2022 走看看