zoukankan      html  css  js  c++  java
  • Wolf and Rabbit

    There is a hill with n holes around. The holes are signed from 0 to n-1. 



    A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 

    InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
    OutputFor each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
    Sample Input

    2
    1 2
    2 2

    Sample Output

    NO
    YES

    题意 : 狼可以每次走m步,而这里有n个洞,问是否存在狼无法走到的洞让兔子藏身。
    分析 : 只要n和m存在着最大公约数,那么狼就会一直在0,最大公约数,m的位置上循环,不会走到其他的洞上去。
    这里简单讲一下最大公约数和最小公倍数的算法:
        最大公约数
    int gcd(int i,int j)
    {
        if(j==0)
            return i;
        else
            gcd(j,i%j);
    }
        最小公倍数 = i*j/最大公约数
    代码:
    #include <iostream>
    
    using namespace std;
    
    int gcd(int i,int j)
    {
        if(j==0)
            return i;
        else
            gcd(j,i%j);
    }
    
    int main()
    {
       int T;
       while(cin >> T)
       {
           while(T--)
           {
                int a,b;
                cin >> a >> b;
                if(gcd(a,b)==1)
                    cout << "NO";
                else
                    cout << "YES";
                cout << endl;
           }
       }
    }
     
  • 相关阅读:
    CI框架主题切换的功能
    centos7 编译安装 php7.4
    单用户登陆demo-后者挤到前者,类似QQ
    nginx 负载均衡的配置
    PHP计算每月几周,每周的开始结束日期
    Centos7 编译安装PHP7
    TP 3.2.3 接入PHPMailer
    外部js引用vue实例环境的方式
    linux常用命令
    计算机中的二级制
  • 原文地址:https://www.cnblogs.com/7750-13/p/7270114.html
Copyright © 2011-2022 走看看