zoukankan      html  css  js  c++  java
  • pat甲级 1152 Google Recruitment (20 分)

    In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

    prime.jpg

    The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

    Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

    Input Specification:

    Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

    Output Specification:

    For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

    Sample Input 1:

    20 5
    23654987725541023819
    

    Sample Output 1:

    49877
    

    Sample Input 2:

    10 3
    2468024680
    

    Sample Output 2:

    404

    判断素数。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #define MAX 1000
    #define DMAX 10000
    using namespace std;
    typedef long long ll;
    int l,k;
    char s[MAX + 1];
    bool ispri(int x) {
        if(x <= 1) return false;
        if(x == 2 || x == 3) return true;
        if(x % 6 != 1 && x % 6 != 5) return false;
        for(int i = 5;i * i <= x;i += 6) {
            if(x % i == 0 || x % (i + 2) == 0) return false;
        }
        return true;
    }
    int main() {
        scanf("%d%d",&l,&k);
        scanf("%s",s);
        char ch = 0;
        char ans[11] = "404";
        for(int i = 0;s[i + k - 1];i ++) {
            swap(s[i + k],ch);
            int d = atoi(s + i);
            if(ispri(d)) {
                strcpy(ans,s + i);
                break;
            }
            swap(s[i + k],ch);
        }
        puts(ans);
        return 0;
    }
  • 相关阅读:
    Service
    adb server is out of date
    Notification.Builder
    eclipse连接小米2调试程序的问题
    Date类
    this指向冒泡排序二分查找
    Dom事件键盘事件
    Dom事件键盘事件
    12.4Dom事件键盘事件
    事件对象
  • 原文地址:https://www.cnblogs.com/8023spz/p/10104895.html
Copyright © 2011-2022 走看看