zoukankan      html  css  js  c++  java
  • 7-1 Maximum Subsequence Sum (25分)

    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    
     

    Sample Output:

    10 1 4

    代码:
    #include <stdio.h>
    #include <string.h>
    
    int main() {
        int n,d,sum = 0,ans = -1,ll,flag = 0;
        scanf("%d",&n);
        int l = 0,r = n - 1,f;
        for(int i = 0;i < n;i ++) {
            scanf("%d",&d);
            if(d >= 0) flag = 1;
            if(sum < 0) sum = 0,ll = d;
            if(i == 0) f = ll = d;
            sum += d;
            if(sum > ans) ans = sum,l = ll,r = d;
        }
        if(flag == 0) ans = 0,l = f,r = d;
        printf("%d %d %d",ans,l,r);
        return 0;
    }
  • 相关阅读:
    Swift:属性观察器
    swift:谈谈swift几种常见属性的区别
    iOS:崩溃统计工具Crashlytics的使用
    【互动出版网】2013双11全场科技图书六折包邮
    【互动出版网】11.11购物狂欢节重磅大促,免费领万千优惠券
    C#编程兵书
    C++编程兵书
    HTML+CSS网站开发兵书
    Java编程兵书
    网络运维与管理2013超值精华本
  • 原文地址:https://www.cnblogs.com/8023spz/p/12255934.html
Copyright © 2011-2022 走看看