zoukankan      html  css  js  c++  java
  • Wireless Network 并查集

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
    Input
    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
    1. "O p" (1 <= p <= N), which means repairing computer p.
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

    The input will not exceed 300000 lines.
    Output
    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
    Sample Input
    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    
    Sample Output
    FAIL
    SUCCESS
    

    遇到这种坐标求距离的最好就是输入double精确度高,然后并查集


    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <queue>
    #include <string>
    #include <cmath>
    using namespace std;
    int n,d,p,q;
    char ch;
    int f[1002];
    int stack[1002],head;
    struct loc
    {
        double x,y;
        int id;
    }ro[1002];
    void init()
    {
        for(int i=1;i<=n;i++)
            f[i]=i;
    }
    int getf(int x)
    {
        if(x!=f[x])f[x]=getf(f[x]);
        return f[x];
    }
    int merge(int x,int y)
    {
        int xx=getf(x),yy=getf(y);
        f[yy]=xx;
    }
    void check(int a,int b)
    {
        if(sqrt(pow(ro[a].x-ro[b].x,2)+pow(ro[a].y-ro[b].y,2))<=d)merge(a,b);
    }
    int main()
    {
       scanf("%d %d",&n,&d);
       init();
       for(int i=1;i<=n;i++)
       {
           scanf("%lf%lf",&ro[i].x,&ro[i].y);
       }
    
       while(cin>>ch)
       {
           if(ch=='O')
           {
               scanf("%d",&p);
               stack[head++]=p;
               for(int i=0;i<head-1;i++)
               {
                  check(stack[i],p);
               }
           }
           else
           {
               scanf("%d %d",&p,&q);
               if(getf(p)==getf(q))cout<<"SUCCESS"<<endl;
               else cout<<"FAIL"<<endl;
           }
       }
    }
  • 相关阅读:
    博士考试复习过程总结
    制作在Linux、Unix上以daemon方式启动Apusic的详细步骤(转)
    重开Blog
    给计算机的兄弟姐妹们补补身体→煲银耳粥
    被人夸成像设计师,高兴呐
    今天问题总结(Hibernate配置参数访问Oracle,Linux下的Apusic自启动)
    HDU ACM 1272 小希的迷宫
    Uva 10115 Automatic Editing
    HDU ACM 1162 Eddy's picture(MST)
    Uva 10474 Where is the Marble?(水题)
  • 原文地址:https://www.cnblogs.com/8023spz/p/7217535.html
Copyright © 2011-2022 走看看