zoukankan      html  css  js  c++  java
  • The Suspects 并查集

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
    Input
    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
    Output
    For each case, output the number of suspects in one line.
    Sample Input
    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0
    Sample Output
    4
    1
    1


    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <queue>
    #include <string>
    #include <cmath>
    using namespace std;
    int n,m,f[30001],k,ex[30001],c;
    int init()
    {
        for(int i=0;i<n;i++)
            f[i]=i;
    }
    int getf(int x)
    {
        if(f[x]!=x)f[x]=getf(f[x]);
        return f[x];
    }
    int merge(int x,int y)
    {
        int xx=getf(x),yy=getf(y);
        f[yy]=xx;
    }
    int main()
    {
        while(scanf("%d%d",&n,&m))
        {
            c=1;
            if(!m&&!n)break;
            init();
            for(int i=0;i<m;i++)
            {
                scanf("%d",&k);
                for(int i=0;i<k;i++)
                {
                    scanf("%d",&ex[i]);
                    if(i>0)merge(ex[i-1],ex[i]);
                }
            }
            int fa=getf(0);
            for(int i=1;i<n;i++)
                if(getf(i)==fa)c++;
            cout<<c<<endl;
        }
    }
  • 相关阅读:
    react跳转url,跳转外链,新页面打开页面
    如何把大段文字转为带html标签的文字
    react给一个div行内加背景图片并实现cover覆盖模式居中显示
    react获取当前页面的url参数
    mongodb查询数据库中某个字段中的值包含某个字符串的方法
    react实现多行文本超出加省略号
    小程序首页获取数据给数组赋值,实现加载更多,以及遇到的坑
    小程序渲染html的两种方法
    小程序url传参如何写变量
    小程序在父组件执行子组件方法,可适用于下拉刷新上拉加载之后执行子组件方法
  • 原文地址:https://www.cnblogs.com/8023spz/p/7219666.html
Copyright © 2011-2022 走看看