zoukankan      html  css  js  c++  java
  • Let the Balloon Rise map一个数组

    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.

    InputInput contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
    OutputFor each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
    Sample Output
    red
    pink

    代码:

    #include <iostream>
    #include <cstdio>
    #include <queue>
    #include <map>
    using namespace std;
    
    int main()
    {
        int n;
        string a,max="a";
        map<string,int> b;
        while(scanf("%d",&n)&&n)
        {
            b[max]=0;
            for(int i=1;i<=n;i++)
            {
                cin>>a;
                b[a]++;
                if(b[a]>b[max])max=a;
            }
            cout<<max<<endl;
        }
    }
  • 相关阅读:
    springboot 多日志
    物联⽹项目框架
    IDEA 行注释、块注释、方法或类说明注释。
    c#监听tomcat服务
    active mq start
    物联网使用启动命令 Redis activemq
    最新通达OA11.6文件删除+任意文件上传rce漏洞复现
    KTS7 kibana模板
    C/C++ 程序反调试的方法
    友情链接
  • 原文地址:https://www.cnblogs.com/8023spz/p/7224910.html
Copyright © 2011-2022 走看看