zoukankan      html  css  js  c++  java
  • 7-19 PAT Judge(25 分)

    The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 3 positive integers, N (104​​), the total number of users, K (5), the total number of problems, and M (105​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

    user_id problem_id partial_score_obtained
    

    where partial_score_obtained is either 1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, you are supposed to output the ranklist in the following format:

    rank user_id total_score s[1] ... s[K]
    

    where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

    The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

    Sample Input:

    7 4 20
    20 25 25 30
    00002 2 12
    00007 4 17
    00005 1 19
    00007 2 25
    00005 1 20
    00002 2 2
    00005 1 15
    00001 1 18
    00004 3 25
    00002 2 25
    00005 3 22
    00006 4 -1
    00001 2 18
    00002 1 20
    00004 1 15
    00002 4 18
    00001 3 4
    00001 4 2
    00005 2 -1
    00004 2 0
    

    Sample Output:

    1 00002 63 20 25 - 18
    2 00005 42 20 0 22 -
    2 00007 42 - 25 - 17
    2 00001 42 18 18 4 2
    5 00004 40 15 0 25 -
    

    就是个结构体,进行qsort,被迫用c写,最后一个测试点总是不对,认真看了题,只要通过编译,就要输出排名,所以忽略了对0分的判断。

    代码:

    #include <stdio.h>
    #include <stdlib.h>
    
    struct stu
    {
        int id;
        int csco;
        int ques[5];
        int cor;
        int flag;
    }s[10001];
    int cmp(const void *a,const void *b)
    {
        struct stu *aa = (void *)a,*bb = (void *)b;
        if(aa->csco == bb->csco)
        {
            if(aa->cor == bb->cor)return aa->id>bb->id?1:-1;
            return aa->cor > bb->cor?-1:1;
        }
        return aa->csco > bb->csco?-1:1;
    }
    int main()
    {
        int n,k,m,d = 1,c = 0;
        int mf[5];
        scanf("%d%d%d",&n,&k,&m);
        for(int i = 0;i < n;i ++)
        {
            s[i].csco = s[i].cor = s[i].flag = 0;
            s[i].id = i + 1;
            for(int j = 0;j < k;j ++)
            {
                s[i].ques[j] = -2;
            }
        }///
        for(int i = 0;i < k;i ++)
            scanf("%d",&mf[i]);
        int id,whi,sco;
        for(int i = 0;i < m;i ++)
        {
            scanf("%d%d%d",&id,&whi,&sco);
            if(s[id - 1].ques[whi - 1] < sco)
            {
                if(sco >= 0)s[id - 1].flag = 1;
                if(sco >= 0)
                {
                    if(s[id - 1].ques[whi - 1] >= 0)
                    s[id - 1].csco += sco - s[id - 1].ques[whi - 1];
                    else
                    s[id - 1].csco += sco;
                }
                s[id - 1].ques[whi - 1] = sco;
                if(s[id - 1].ques[whi - 1] == mf[whi - 1])s[id - 1].cor ++;
            }
        }
        qsort(s,n,sizeof(s[0]),cmp);
        for(int i = 0;i < n;i ++)
        {
            if(i > 0 && s[i].csco != s[i - 1].csco)
            {
                d = c + 1;
            }
            if(s[i].flag)
            {
                c ++;
                printf("%d %05d %d",d,s[i].id,s[i].csco);
                for(int j = 0;j < k;j ++)
                if(s[i].ques[j] == -2)printf(" -");
                else if(s[i].ques[j] == -1)printf(" 0");
                else printf(" %d",s[i].ques[j]);
                putchar('
    ');
            }
        }
    }
  • 相关阅读:
    Java垃圾收集器概述
    redis.clients.jedis.exceptions.JedisConnectionException: Could not get a resource from the pool
    Serialize a Long as a String
    数据库遇到的问题
    解决Safari页面缓存的问题
    idea -> Error during artifact deployment. See server log for details.
    正则表达式
    commons-lang
    Template和Style
    WPF资源
  • 原文地址:https://www.cnblogs.com/8023spz/p/7732602.html
Copyright © 2011-2022 走看看