zoukankan      html  css  js  c++  java
  • 7-17 Hashing(25 分) 整型关键字的平方探测法散列

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (104​​) and N (MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    

    Sample Output:

    0 1 4 -
    

    平方探测法。

    代码:
    #include <cstdio>
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <map>
    using namespace std;
    int is(int n)
    {
        if(n == 1)return 0;
        if(n == 2 || n == 3)return 1;
        if(n % 6 != 1 && n % 6 != 5)return 0;
        for(int i = 5;i * i <= n;i += 6)
        {
            if(n % i == 0 || n % (i + 2) == 0)return 0;
        }
        return 1;
    }
    int main()
    {
        int m,n;
        int s,p,v[10007] = {0};
        scanf("%d %d",&m,&n);
        while(!is(m))m ++;
        for(int i = 0;i < n;i ++)
        {
            p = -1;
            scanf("%d",&s);
            for(int j = 0;j < m;j ++)
            {
                if(!v[(s + j * j) % m])
                {
                    v[(s + j * j) % m] = 1;
                    p = (s + j * j) % m;
                    break;
                }
            }
            if(i)putchar(' ');
            if(p == -1)printf("-");
            else printf("%d",p);
        }
    }
  • 相关阅读:
    js保留两位小数
    js字符串转成数字的三种方法
    『MySQL』索引类型 normal, unique, full text
    checkstyle配置文件说明
    如何更好地利用Pmd、Findbugs和CheckStyle分析结果
    Hibernate SQL优化技巧dynamic-insert="true" dynamic-update="true"
    Struts2 action的单例与多例
    Eclipse插件checkstyle安装使用
    html 动态显示元素文本
    脱离 Spring 实现复杂嵌套事务,之一(必要的概念)
  • 原文地址:https://www.cnblogs.com/8023spz/p/7746524.html
Copyright © 2011-2022 走看看