zoukankan      html  css  js  c++  java
  • poj 2001 Shortest Prefixes

    A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

    In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

    An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".
    Input
    The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
    Output
    The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
    Sample Input
    carbohydrate
    cart
    carburetor
    caramel
    caribou
    carbonic
    cartilage
    carbon
    carriage
    carton
    car
    carbonate
    
    Sample Output
    carbohydrate carboh
    cart cart
    carburetor carbu
    caramel cara
    caribou cari
    carbonic carboni
    cartilage carti
    carbon carbon
    carriage carr
    carton carto
    car car
    carbonate carbona
    
    找最短的前缀,且这个前缀不被其他单词共用。
    字典树,没有复杂操作。
    链表版。
    代码:
    #include <iostream>
    #include <string>
    
    using namespace std;
    struct Trie {
        int c;
        Trie *next[26];
    };
    Trie *CreateNode() {
        Trie *p = new Trie;
        p -> c = 0;
        for(int i = 0;i < 26;i ++) {
            p -> next[i] = NULL;
        }
        return p;
    }
    Trie *Insert(Trie *head,string a) {
        Trie *h = head;
        for(int i = 0;i < a.size();i ++) {
            if(head -> next[a[i] - 'a'] == NULL) {
                head -> next[a[i] - 'a'] = CreateNode();
            }
            head = head -> next[a[i] - 'a'];
            head -> c ++;
        }
        return h;
    }
    void print(Trie *head,string a) {
        for(int i = 0;i < a.size();i ++) {
            head = head -> next[a[i] - 'a'];
            if(head == NULL)return;
            if(head -> c > 1)cout<<a[i];
            else if(head -> c == 1) {
                cout<<a[i];
                return;
            }
        }
    }
    int main() {
        string a[1005];
        int i = 0;
        Trie *head = CreateNode();
        while(cin>>a[i]) {
            head = Insert(head,a[i ++]);
        }
        for(int j = 0;j < i;j ++) {
            cout<<a[j]<<' ';
            print(head,a[j]);
            cout<<endl;
        }
    }
  • 相关阅读:
    Adding links to a Panel container’s status text in Flex
    修改flex应用默认的装载界面
    在Flex中复制文字到操作系统的剪贴板
    kubernetesdashboard安装
    需求分析与代码设计统一新方法(摘自:Jdon创始人彭晨阳)
    System.IO命名空间
    第一篇随笔怎么写?
    Linux下使用VsCode进行Qt开发环境搭建 TssiNG
    Apache Rewrite实现URL的跳转和域名跳转
    Subversion1.6.6 + apache2.2.14 + windows安装配置
  • 原文地址:https://www.cnblogs.com/8023spz/p/7786878.html
Copyright © 2011-2022 走看看