zoukankan      html  css  js  c++  java
  • 1004. Counting Leaves (30)

    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

    Input

    Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    Output

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

    Sample Input

    2 1
    01 1 02
    

    Sample Output

    0 1
    
    构造树,层层递归计算叶子数。
    代码:
    #include <stdio.h>
    #include <stdlib.h>
    struct Node
    {
        int index;
        int c[101];
    }s[101];
    int leave[101];
    int mheight = 0;
    void count(int id,int height)
    {
        if(mheight < height)mheight = height;
        if(s[id].index == 0)
        {
            leave[height] ++;
            return;
        }
        for(int i = 0;i < s[id].index;i ++)
            count(s[id].c[i],height + 1);
    }
    int main()
    {
        int n,m,k,id,d;
        scanf("%d%d",&n,&m);
        for(int i = 0;i < m;i ++)
        {
            scanf("%d%d",&id,&k);
            s[id].index = 0;
            while(k --)
            {
                scanf("%d",&d);
                s[id].c[s[id].index ++] = d;
            }
        }
        count(1,0);
        printf("%d",leave[0]);
        for(int i = 1;i <= mheight;i ++)
            printf(" %d",leave[i]);
    }
  • 相关阅读:
    安装centos后无法引导启动windows7的解决方法
    Ubuntu14.04 搜索不到WIFI或连接不上的解决方法。
    ubuntu磁盘分区问题
    Cenos7下nginx+mysql+php环境的搭建
    PHP发送邮件
    php使用数据库的并发问题(乐观锁与悲观锁)
    总结一些php的面试题
    遇到高并发一些处理方法
    PHP中9大缓存技术总结
    php并发加锁示例
  • 原文地址:https://www.cnblogs.com/8023spz/p/7932081.html
Copyright © 2011-2022 走看看