zoukankan      html  css  js  c++  java
  • 1024. Palindromic Number (25)

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:
    67 3
    
    Sample Output 1:
    484
    2
    
    Sample Input 2:
    69 3
    
    Sample Output 2:
    1353
    3
    

    代码:

    #include <iostream>
    #include <cstring>
    #include <queue>
    #include <string>
    #include <cstdlib>
    #include <algorithm>
    using namespace std;
    int main()
    {
        char a[200],b[200];
        int c = 0,d,i;
        cin>>a>>d;
        int len = strlen(a);
        strcpy(b,a);
        reverse(a,a+len);
        for(i = 0;i < d;i ++)
        {
           if(strcmp(a,b) == 0)break;
           for(int j = 0;j < len;j ++)
           {
               c += a[j] - '0' + b[j] - '0';
               a[j] = c % 10 + '0';
               c /= 10;
           }
           if(c)
           {
               a[len ++] = '0' + c % 10;
               c /= 10;
               a[len] = '';
           }
           strcpy(b,a);
           reverse(a,a+len);
        }
        cout<<a<<endl<<i;
    }
  • 相关阅读:
    vim编辑参数
    hive的元数据存储在mysql后,报错的解决方法!
    hadoop添加删除节点
    Android画图Path的使用
    android中path的arcTo方法的使用 .
    StrongReference、SoftReference、WeakReference、PhantomReference .
    为Android应用增加渠道信息 自动化不同渠道的打包过程
    C#知识点
    CSS判断浏览器
    调用外部程序
  • 原文地址:https://www.cnblogs.com/8023spz/p/7944557.html
Copyright © 2011-2022 走看看