zoukankan      html  css  js  c++  java
  • 1029. Median (25)

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output

    For each test case you should output the median of the two given sequences in a line.

    Sample Input
    4 11 12 13 14
    5 9 10 15 16 17
    
    Sample Output
    13
    

    排序
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    #include <set>
    #include <algorithm>
    using namespace std;
    
    long long s[2000000];
    int main()
    {
        int a,b;
        scanf("%d",&a);
        for(int i = 0;i < a;i ++)
        {
            scanf("%lld",&s[i]);
        }
        scanf("%d",&b);
        b += a;
        for(int i = a;i < b;i ++)
        {
            scanf("%lld",&s[i]);
        }
        sort(s,s+b);
        printf("%lld",s[(b-1)/2]);
    }

     维护大小为(a+b)/2的堆。

    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <queue>
    #include <algorithm>
    using namespace std;
    int main() {
        priority_queue<int,vector<int>,less<int> >q;
        int a,b,d,mid;
        scanf("%d",&a);
        for(int i = 0;i < a;i ++) {
            scanf("%d",&d);
            q.push(d);
        }
        scanf("%d",&b);
        mid = a + b;
        mid = (mid % 2) ? (mid / 2 + 1) : (mid / 2);
        while(q.size() > mid)q.pop();
        while(b && q.size() < mid) {
            scanf("%d",&d);
            b --;
            q.push(d);
        }
        for(int i = 0;i < b;i ++) {
            scanf("%d",&d);
            if(q.top() > d) {
                q.pop();
                q.push(d);
            }
        }
        printf("%d",q.top());
    }
  • 相关阅读:
    强连通分量
    mysql安装图解 mysql图文安装教程(详细说明)
    MeshCombineUtility.cs method `GetTriangleStrip' of type `UnityEngine.Mesh' could be found
    socket网络编程之一:客户端和服务器端接口函数
    unity3D——登录界面
    Ionic学习注意事项01
    这里我将分享我学到的几种ionic登陆界面
    关于ionic基础教程的学习网址
    Windows下配置Git
    Cocos网络篇[3.2](3) ——Socket连接(1)
  • 原文地址:https://www.cnblogs.com/8023spz/p/7967799.html
Copyright © 2011-2022 走看看