zoukankan      html  css  js  c++  java
  • 1070. Mooncake (25)

    Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

    Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

    Sample Input:

    3 200
    180 150 100
    7.5 7.2 4.5
    

    Sample Output:

    9.45
    产量和寻求量都用double不一定是整数。
    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    using namespace std;
    struct mcake
    {
        double num,sprice,price;
    }s[1000];
    bool cmp(mcake a,mcake b)
    {
        return a.price > b.price;
    }
    int main()
    {
        int n;
        double c = 0,d;
        scanf("%d%lf",&n,&d);
        for(int i = 0;i < n;i ++)
        {
            scanf("%lf",&s[i].num);
        }
        for(int i = 0;i < n;i ++)
        {
            scanf("%lf",&s[i].sprice);
            s[i].price = s[i].sprice / s[i].num;
        }
        sort(s,s+n,cmp);
        for(int i = 0;i < n;i ++)
        {
            if(d >= s[i].num)
            {
                d -= s[i].num;
                c += s[i].sprice;
            }
            else
            {
                c += s[i].price * d;
                break;
            }
        }
        printf("%.2f",c);
    }
  • 相关阅读:
    利用python 学习数据分析 (学习四)
    numpy 模块常用方法
    利用python 学习数据分析 (学习三)
    numpy 常用方法2
    瞎JB逆
    Codeforces 907 矩阵编号不相邻构造 团操作状压DFS
    AT Regular 086
    矩阵快速幂 求斐波那契第N项
    指数循环节(指数降幂)
    Educational Codeforces Round 32
  • 原文地址:https://www.cnblogs.com/8023spz/p/8205563.html
Copyright © 2011-2022 走看看