zoukankan      html  css  js  c++  java
  • 1079. Total Sales of Supply Chain (25)

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki ID[1] ID[2] ... ID[Ki]

    where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

    Sample Input:
    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3
    
    Sample Output:
    42.4

    比较简单。
    代码:
    #include <iostream>
    #include <cstdio>
    using namespace std;
    int f[100001],ans[100001],amount[100001],no;///f记录每个点的上一个点 ans记录retailer的编号 amount记录ans相应位置retailer的total amount of product  no是下标
    int n;
    double p,r,up[100001];///up记录价格
    void fetch(int i)///计算 i的价格 
    {
        if(up[i] == 0)///表示i的价格未知 要计算上一个点的价格 
        {
            if(f[i])fetch(f[i]);///如果f[i]为0 就不用计算了
            up[i] = r * up[f[i]];
        }
    }
    void compute()
    {
        double sum = 0;
        for(int i = 0;i < no;i ++)
            sum += up[ans[i]] * amount[i];
        printf("%.1f",sum);
    }
    int main()
    {
        scanf("%d %lf %lf",&n,&p,&r);
        r = (1 + r / 100);
        up[0] = p;
        int k,d;
        for(int i = 0;i < n;i ++)
        {
            scanf("%d",&k);
            if(k)
            for(int j = 0;j < k;j ++)
            {
                scanf("%d",&d);
                f[d] = i;
            }
            else
            {
                scanf("%d",&d);
                amount[no] = d;
                ans[no ++] = i;
                fetch(i);
            }
        }
        compute();
    }
  • 相关阅读:
    基于VMWare配置VxWorks开发环境
    Go 方法、接口
    cgo 和 Go 语言是两码事
    MFC的回调函数
    go语言将函数作为参数传递
    nginx源码学习资源
    PYTHON 自动化运维
    LVS中文站点
    MS SQL SERVER 书BOOK
    桦仔------分享一下我研究SQLSERVER以来收集的笔记
  • 原文地址:https://www.cnblogs.com/8023spz/p/8276016.html
Copyright © 2011-2022 走看看