zoukankan      html  css  js  c++  java
  • 1093. Count PAT's (25)

    The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

    Now given any string, you are supposed to tell the number of PAT's contained in the string.

    Input Specification:

    Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.

    Output Specification:

    For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

    Sample Input:
    APPAPT
    
    Sample Output:
    2
    
    遇到p计算p的数量,遇到a计算a的数量,遇到一个t就算一下t前面有多少个pa,而计算pa就是每个a之前有几个p,所以遇到不是a的(p或t),先看一下a是否为0,如果不是,就pa += p * a,pa的数量增加,然后a归零。
    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cmath>
    #include <iomanip>
    using namespace std;
    int main()
    {
        int pa = 0,pat = 0,p = 0,a = 0;
        char s[100005];
        cin>>s;
        for(int i = 0;s[i];i ++)
        {
            if(s[i] == 'P')
            {
                if(a)
                {
                    pa += p * a;
                    a = 0;
                }
                p ++;
            }
            else if(s[i] == 'A')a ++;
            else
            {
                if(a)
                {
                    pa += p * a;
                    a = 0;
                }
                pat = (pat + pa) % 1000000007;
            }
        }
        cout<<pat;
    }

  • 相关阅读:
    jmeter测试mysql数据库之JDBC请求
    接口测试浅谈
    python import xxx 与 from xxx import xx 模块引入的区别
    交互模式下测试python代码及变量的四则运算
    python入门之一python安装及程序运行
    zabbix命令之:zabbix_get命令
    snmpwalk工具使用
    zabbix基础知识
    Centos7.5 rpm安装zabbix_agent4.0.3
    mysql常用命令
  • 原文地址:https://www.cnblogs.com/8023spz/p/8394896.html
Copyright © 2011-2022 走看看