zoukankan      html  css  js  c++  java
  • 1109. Group Photo (25)

    Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

    • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
    • All the people in the rear row must be no shorter than anyone standing in the front rows;
    • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
    • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
    • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

    Now given the information of a group of people, you are supposed to write a program to output their formation.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains two positive integers N (<=10000), the total number of people, and K (<=10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

    Output Specification:

    For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

    Sample Input:
    10 3
    Tom 188
    Mike 170
    Eva 168
    Tim 160
    Joe 190
    Ann 168
    Bob 175
    Nick 186
    Amy 160
    John 159
    
    Sample Output:
    Bob Tom Joe Nick
    Ann Mike Eva
    Tim Amy John
    
    排位置,最高的排在后面,第i排的人的身高必须比第i+1排的人都高,排成k排,每排(int)(n/k)人,多出来的排在第一排,每一排按照最高的在中间,然后按照递减的模式,左边一个右边一个,左边一个。。。一直下去
    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int n,k;
    struct peo
    {
        char name[10];
        int height;
    }s[10000];
    bool cmp(peo a,peo b)
    {
        if(a.height == b.height)return strcmp(a.name,b.name) > 0;
        return a.height < b.height;
    }
    int main()
    {
        cin>>n>>k;
        for(int i = 0;i < n;i ++)
        {
            cin>>s[i].name>>s[i].height;
        }
        sort(s,s + n,cmp);
        int d = n / k,e = n % k,f = n;
        e += d;
        while(f)
        {
            for(int i = e % 2 ? f - e + 1 : f - e;i < f;i += 2)
            {
                cout<<s[i].name<<' ';
            }
            cout<<s[f - 1].name;
            for(int i = f - 3;i >= f - e;i -= 2)
            {
                cout<<' '<<s[i].name;
            }
            cout<<endl;
            f -= e;
            if(e != d)e = d;
        }
    }
  • 相关阅读:
    find命令 -- 之查找指定时间内修改过的文件
    nginx
    lighttpd 搭建
    mysql主从复制5.6基于GID及多线程的复制笔记
    centos下MySQL主从同步配置
    数据库集群搭建
    linux 系统监控、诊断工具之 top 详解
    Linux下Apache并发连接数和带宽控制
    DXGI屏幕捕捉
    CUDA以及CUDNN安装配置(WIN10为例)
  • 原文地址:https://www.cnblogs.com/8023spz/p/8490193.html
Copyright © 2011-2022 走看看