zoukankan      html  css  js  c++  java
  • 1117. Eddington Number(25)

    British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

    Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

    Output Specification:

    For each case, print in a line the Eddington number for these N days.

    Sample Input:
    10
    6 7 6 9 3 10 8 2 7 8
    
    Sample Output:
    6
    
    找出一个E,有E天,行程超过E miles,先从小到大排序,从后往前看,如果当前看了s个数,而最后一个数又比s大,那么s满足条件,找出最大的s。
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int s[100005];
    int n,m;
    int main()
    {
        cin>>n;
        for(int i = 0;i < n;i ++)
        {
            cin>>s[i];
        }
        sort(s,s + n);
        for(int i = n - 1;i >= 0;i --)
        {
            if(s[i] > n - i && m < n - i)m = n - i;
        }
        cout<<m;
    }
  • 相关阅读:
    Linux文件和目录的权限
    nginx的默认web目录
    SSH-keygen rsa 密钥对根据私钥生成公钥
    对ajax的理解
    开关式复选框的操作
    关于弹框和原页面的切换问题
    单选框和复选框中value值得获取
    php中明明写了类函数,却报致命错误找不到类
    python函数
    python关键字
  • 原文地址:https://www.cnblogs.com/8023spz/p/8491647.html
Copyright © 2011-2022 走看看