zoukankan      html  css  js  c++  java
  • 1118. Birds in Forest (25)

    Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
    K B1 B2 ... BK
    where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

    After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

    Output Specification:

    For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.

    Sample Input:
    4
    3 10 1 2
    2 3 4
    4 1 5 7 8
    3 9 6 4
    2
    10 5
    3 7
    
    Sample Output:
    2 10
    Yes
    No
    
    简单并查集。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int f[10005],n,k,a,b,c,m;
    int getf(int x)
    {
        if(f[x] != x)f[x] = getf(f[x]);
        return f[x];
    }
    void mer(int x,int y)
    {
        int xx = getf(x);
        int yy = getf(y);
        f[xx] = yy;
    }
    void init()
    {
        for(int i = 1;i <= 10000;i ++)
        {
            f[i] = i;
        }
    }
    int main()
    {
        cin>>n;
        init();
        for(int i = 0;i < n;i ++)
        {
            cin>>k;
            cin>>a;
            if(a > m)m = a;
            for(int j = 1;j < k;j ++)
            {
                cin>>b;
                if(b > m)m = b;
                mer(a,b);
            }
        }
        for(int i = 1;i <= m;i ++)
        {
            if(getf(i) == i)c ++;
        }
        cout<<c<<' '<<m<<endl;
        cin>>k;
        for(int i = 0;i < k;i ++)
        {
            cin>>a>>b;
            if(f[a] == f[b])cout<<"Yes"<<endl;
            else cout<<"No"<<endl;
        }
    }
  • 相关阅读:
    LR三:post接口_ajax上传
    LR二:post接口_form表单上传
    Dijkstra优先队列优化
    Misha and Changing Handles
    HDU-1428(记忆化搜索)
    CF-599B
    POJ-1488(字符串应用)
    New Year Permutation(Floyd+并查集)
    HDU-1078
    HDU-5532(LIS-nlogn)
  • 原文地址:https://www.cnblogs.com/8023spz/p/8492105.html
Copyright © 2011-2022 走看看