zoukankan      html  css  js  c++  java
  • 1126. Eulerian Path (25)

    In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

    Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

    Output Specification:

    For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

    Sample Input 1:
    7 12
    5 7
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    7 6
    6 3
    4 5
    6 4
    5 6
    
    Sample Output 1:
    2 4 4 4 4 4 2
    Eulerian
    
    Sample Input 2:
    6 10
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    6 3
    4 5
    6 4
    5 6
    
    Sample Output 2:
    2 4 4 4 3 3
    Semi-Eulerian
    
    Sample Input 3:
    5 8
    1 2
    2 5
    5 4
    4 1
    1 3
    3 2
    3 4
    5 3
    
    Sample Output 3:
    3 3 4 3 3
    Non-Eulerian
    并查集判断是否连通。然后判断是不是欧拉回路或者欧拉通路。欧拉回路是所有点的度数都是偶数,欧拉通路有两个点的度数是奇数。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int n,m,v[501],a,b,odd,pic;
    int f[501];
    int getf(int x)
    {
        if(x != f[x])f[x] = getf(f[x]);
        return f[x];
    }
    void mer(int x,int y)
    {
        int xx = getf(x);
        int yy = getf(y);
        f[xx] = yy;
    }
    void init()
    {
        for(int i = 1;i <= n;i ++)
            f[i] = i;
    }
    int main()
    {
        cin>>n>>m;
        init();
        for(int i = 0;i < m;i ++)
        {
            cin>>a>>b;
            mer(a,b);
            v[a] ++;
            v[b] ++;
        }
        for(int i = 1;i <= n;i ++)
        {
            if(f[i] == i)pic ++;
            if(i != n)cout<<v[i]<<' ';
            else cout<<v[i]<<endl;
            if(v[i] % 2)odd ++;
        }
        if(pic == 1 && odd == 2)cout<<"Semi-Eulerian";
        else if(pic == 1 && odd == 0)cout<<"Eulerian";
        else cout<<"Non-Eulerian";
    }
  • 相关阅读:
    springboot之热部署
    在动态sql的使用where时,if标签判断中,如果实体类中的某一个属性是String类型,那么就可以这样来判断连接语句:
    对集合进行判空的操作
    配置logback日志管理的时候
    SpringBoot序列化时间类型的问题
    Cannot determine embedded database driver class for database type NONE
    idea的基础设置
    使用navicat创建数据库
    LESS
    数据库链接池--简单的理解
  • 原文地址:https://www.cnblogs.com/8023spz/p/8494581.html
Copyright © 2011-2022 走看看